Hacking/Rigging problems with Fallout: New Vegas models

Hey all, I’ve been trying to rig for a while, but I’ve been having some really strange problems that I can’t seem to fix.

This is the model I’m trying to hack and rig. I’m using the HL2 citizen skeleton, and the finger bones from the Fallout skeleton attached to the hand bones. The mesh is split up into different parts, the gloves are different models, as are the hands, torso/legs, and the arms are seperate too. When I try to attach the models it unsmooths, but I’ll get into that later.
[img_thumb]http://dl.dropbox.com/u/17839936/rigging%20problems%201.jpg[/img_thumb]

I added the forearm bone to this piece of the mesh to try and rig.
[img_thumb]http://dl.dropbox.com/u/17839936/rigging%20problems%202.jpg[/img_thumb]

…and setting the weight sends the model back to the original scale/rotation positions the model started in when I imported the original mesh. I have no idea why this happens.
[img_thumb]http://dl.dropbox.com/u/17839936/rigging%20problems%203.jpg[/img_thumb]

Moving the bone doesn’t help any, but it is weighted still.
[img_thumb]http://dl.dropbox.com/u/17839936/rigging%20problems%204.jpg[/img_thumb]

This is where another strange error comes in. The bones I am weighting are added to this mesh’s skin modifier so I can rig them.
[img_thumb]http://dl.dropbox.com/u/17839936/rigging%20problems%205.jpg[/img_thumb]

The weighting doesn’t work and ends up casting this strange shadow.
[img_thumb]http://dl.dropbox.com/u/17839936/rigging%20problems%206.jpg[/img_thumb]

Trying to move the bone to see if it actually worked, in case this was just a strange bug. It didn’t work.
[img_thumb]http://dl.dropbox.com/u/17839936/rigging%20problems%207.jpg[/img_thumb]

This is pretty much a culmination of the problems. After attaching the meshes together, the attached pieces became unsmoothed, they returned to the original scale of the original model import, and they returned to the original rotation when I applied a weight to them.
[img_thumb]http://dl.dropbox.com/u/17839936/rigging%20problems%208.jpg[/img_thumb]

I am truly at a loss of what’s causing these issues. I really would appreciate some help if anybody knows what the problem is, if you can help please post in the thread. Thanks a ton!

Pretty sure it’s doing that because it retains its position from when the skin modifier was first added. You’d need to delete the skin modifier and re-add it. I’m not sure of other fixes.

Edit >> delete by type >> history? would that help?

after you do changes to the skeleton, I recommend you export the model to smd and reimport it (or the skeleton)

You more or less clear the history that way, so you don’t get movement issues like these.

Thanks for the posts!

I’ve tried exporting both the skeleton and mesh separately. The skeleton works fine, but when I export then import the smd it unsmoothes itself.

I have tried this and it seems to work. The meshes still unsmooth when I try attaching them though.

Just resmooth it. (though remember to thick off rebuilt normals) It’s due to how importer recontructs the normals.

And how should I go about doing so? I’ve tried autosmooth (I’m not sure if that’s the proper way, so sorry if that was dumb in the first place) and it didn’t quite look right.

And thanks again, for the posts.