Hammer already crashes with a simple skybox with deplacements

Hi,

  • I have made a simple skybox,almost max size, kept some free at each faces
  • Added an inviroment light and a player start
  • Tested the compiling with map vis and vrad all on normal, map came out fine .bsp file around 20mb (seems a little big already but I don’t know)
  • Then opened it again, face editor on floor created 3 displacements then 4 added some hills but every time it crashes on the beginning. No error just program hangs.

I don’t know why my hammer crashes so often but maybe i’m doing something wrong with the skybox. Do I need to make something func_detail or is there another reason.

Oh all unused surfaces are nodraw so I got like 6 faces with textures, 5 toolskybox and 1 dirtfloor

ty

are any of your displacements func_detail?
any func_detail displacements will cause VBSP to fail.

It’s all standard. Just a skybox max map size made with a block, made hollow, 5 faces toolskybox and 1 dirtfloor. And 2 entity’s.

Dirtfloor is made with displacements first create 3 then tried again with 4 and that’s it, crashes.

I’m just trying to make a simple water map with 3 islands in it. Then I want to make some tunnels en bridges.

Should I otherwise use a terrain editor and later cut through the ground on the islands to make a tunnel from there or is there any other (better) technique?

No idea why my hammer is so unstable. But whenever I try to add more than only the skybox it crashes on compiling :frowning:

But I don’t want to skip build options because I want it to look good.

thanks

I just tried another time with displacements create 4 on floor and now the map compiles very fast like 20 secs and is only 1mb and I fall through there is no textures etc.

But without displacements so only skybox and dirtfloor the map takes 2 mins to compile and is 20mb

Compile Log

I’ve start over again and it now seems to work. First it appears to crash but after a minute it finishes compiling. Before it took 10 minutes but still frozen. So that’s good.

However, now my map shows a leak, but the pointfile (red line) points at a brush and everything seems to be ok. I checked checked and double checked and every brush fits tight.

So I removed and remade all the brushes around the area where the red line is pointing and saved it and ran it again but still it says leak.

It does compile though, but the big text ‘LEAKED’ bothers me cause I want it to be perfect this time.

Here’s the log:

.bsp is 12.889mb

Did you use another brush under the displacement? Displacements don’t seal the map, only brushes.

EDIT: You can also upload the VMF for other people to look at.

No I did not. Lol so that is probably the problem.

Should I carefully nodraw around the displacements or just put a big skybox size nodraw on the bottom over the entire map? Which is better for performance? 1 big brush or 50 small ones. I hope 1 big brush cause it saves time.

Thank you, I might upload the VMF whenever I get stuck :slight_smile:

I’ve sealed off the displacements now, saved the map and when I compile the compiler keeps hanging on not responding for more than 10 minutes so I shut it off again with ctrl alt delete (took very long to do so).

The mapsize now is only 2mb but it seems to work fine. But i’m not sure if it should be so less filesize? However, I can’t read the log as it crashes so I don’t know if it’s still leaked or has any other errors.

It doesn’t say with load pointfile so I guess it’s not leaked anymore, but still I would like to somehow see the log at the end of the compiling.

What should I do?

You let it finish compiling, the hammer compile window doesn’t update for a while, so windows assumes it’s broken and says it’s not responding, it’s because you have a large open area as your whole map, so it’s going to take a long time to compile. Just be patient.

Thank you for your quick reply.

I’ve already waited 5 times longer than normally, and also the mapsize is 6 times as small as normal (with previous version).

So I thought that was enough.

I’ll try again and then leave the pc for 15 mins see if I can access the compile log afterwards.

Updates will follow

// Edit

That’s so odd. I’ve just opened the exact same file and compiled it again with everything set to normal.

And guess what? It compiled without showing Not Responding. It took almost 15 minutes though but the log still says less than 1 minute.

Here is the log, maybe someone can tell me if everything is looking alright? Then I can start the real big work. But i’ve learned to give it some time and maybe a few tries at first so thanks for that.

Mapsize 13mb