Hammer crashes almost every time I enter the 'Flags' tab in object properties

Over half of the times I click the flags tab in the object properties for an entity, Hammer crashes without any error.
It hasn’t always been like this, it was after the last update.
I’ve tried finding a solution, but I only found dead threads without a solution.
Anyone else have this problem?

no, I have not had this issue, but have you tried the obvious? refresh SDK content, restart steam, restart PC?

If nothing else works, backup your map files (just in case) and reinstall Source SDK

Already done all of that :frowning:

Weird, what OS are you running? I thought I read about Vista having compatibility issues with Hammer.

But I’m running Vista and it works fine :S

Vista x64.
Worked fine before the update, and I still had Vista.
I do have dual monitors though and I think I got it around the same time the update was released.
Do you think that could be the problem?

Wait, update? When was this? It might’ve affected me too.

Can’t remember.
A few weeks ago.
You have dual monitor setup too?

Nope, but I have Vista. I thought it might be to do with that. I’ve been using hammer the past few days so I think I must have the update. Confusing.

Is it happening on every map?

Yeah, but I’m not sure if it’s for every game config.
I’ll try the TF2 one.

Edit:

TF2 SDK crashed too

I’ve had problems with 64-bit as well, XP then. I went back to regular x32 and it worked fine.

Look up the flags manually in the dev wiki, turn off smartedit, and then add the relevant number to ‘spawnflags’.

To set multiple flags, add their numbers together and type that in the box.

This will prevent you from having to use the flags tab.

Alright, I guess I’ll have to use that meanwhile.
I mailed Valve about this; I hope they have a solution

must not of worked its 4 years later and I’m having that problem ._.