Hammer Crashes Every 5 Min

As title says.

Could start a new file, could edit an old one. It still crashes.

Not sure what to do here, if you need any information lemme know and I’ll get it.

have you tied deleting the Bin folder its in then verifying the game cache to dl new tools ?

Still crashing.

does it produce a dump file ? also check if reinstalling grapics works

EDIT
If you are comfortable editing the registry try this https://developer.valvesoftware.com/wiki/Resetting_Hammer_preferences back sure u do a backup :slight_smile:

Still crashing after editing the Registry and it does create a dump file.

which Hammer for what game are you mapping ?

Episode Two hammer.

try downloading the source SDK base 2013 singleplayer https://developer.valvesoftware.com/wiki/Source_SDK_2013#Setting_up_the_Source_SDK_Base its the one with (AppID: 243730) after the link you have HL2ep2 config set up once you do a quick run of the program then go into the Bin folder to start hammer, if you get a crash when starting that version of hammer, it could be a bigger problem than just hammer being a pain in *ss

Still crashing with SDK 2013

can you provide a link to the dump file to look at

.mdmp - Half Life 2 Bin

.mdmp - SDK 2013 Bin

the crash dump were empty, but if you have visual studio 2010 or 2013 express you can open them, if you do and see something like what i’ve circled in red then it means Hammer can access the file where it is, either try moving the file to a folder like the maps folder of hl2ep2 or start Hammer with Admin rights


a crash dump i have

Do you have an excessive amount of custom content?, because if yes could be the thing causing the crashes… it happened with me… i had to dump alot of the content (materials/models/etc) in order to stop the constant crashing.

ah yeah i didn’t think of that with custom content :slight_smile:

Do not click into void.

Removed all my custom content, STILL crashing.

[editline]13th September 2016[/editline]

Completely reinstalled HL2, HL2:EP1 and HL2:EP2. Still crashing.

Disable autosave maybe?

If you’d like to try another Editor give this a try http://sledge-editor.com/ its the same UI style as hammer

Hello, I had this same issue until a few days ago. I tried reinstalling and verifying cache multiple times like you did, but nothing worked.

It seems to be caused by the new AMD graphics drivers. Reverting it back to the February version fixed it.

Cheers for this, I was trying to avoid anything driver related but I’ll give this a shot.

Cheers man.