Hammer crashes when loading a map.

I compiled my singleplayer map, and hl2.exe crashed when it started up. Now when i open up hammer it gets about 10% through loading it, crashes and i have to close it. Can you help me please? It wasn’t a fantastic map and i could probably rebuild it in about 30 minutes but i cant even do File>New because it crashes when i do that aswell…

Seems to me it might be hammer, have you tried rebooting SDK and your computer? if so, try reinstalling SDK, don’t forget to back up your maps etc.

I rebooted, didnt work, i reverified the cache whatevermajigs in the properties of Source SDK, then i reset my game configurations and it’s working now… Thanks Chicken.

[editline]02:57PM[/editline]

You realise i now have to eat you. Omnomnom.

Mhmm… Glad it worked, it’s a common problem many people have, I’ve had it too… I really can’t figure out why it does it…

you cant talk he ate you :v:

I have the same problem, where do I reset the game configurations? What I need to erase?

In source sdk. In the utilities section.

My problem still here. I was creating my map for Counter-Strike: Source when i close hammer for add custom textures. Now when i’m going to open the map with hammer (.vmf) it crashes when its loading at 5%(“reading chunks”), closing automatically without error message. But I haven’t got this problem with other maps. Please help me, it was nearly finished, and i have spend two days on it. What i need to do? What about send you the vmf and you try to compile it?

Sounds like a corrupt vmf.

if you’ve used double quotes (") anywhere in your maps entities it stops the map being loaded by hammer. It may also be caused by a corruption of the vmf caused by a hammer crash whilst saving.

Paste the last few lines of the vmf here in [noparse]




[/noparse] tags. (Open the vmf up with notepad, it’s actually just plain text file)

OMG. ¡THANKS A LOT!

I SOLVED IT. WAS THAT: A FAKKIN QUOTES IN A func_movelinear.

THANKS THANKS THANKS MAN THANKS T_T

Bump. This worked great for me. The trick is finding where the double quotes are. The easiest way I could find was to dump the code into a python window and look for any code that was inside of double quotes that didn’t show up in the color strings were supposed to appear as (for me it was green).

My mistake was I had an output from a timer to a fog controller where the input was supposed to be a color. I didn’t know how to code the color, so I assumes it was “255 0 255”. Of course, this was my mistake since I had used the double quotes. (If you look at the Valve Dev page on color255, it shows the colors in this syntax, which is fucking retarded because it’s clearly wrong). The correct syntax is [255 0 255] (I think?). The reason I’m posting this is because I expect other people will make the same mistake I did.

[editline]28th July 2011[/editline]

And I know how you feel. It is nerve-racking when something you’ve worked on for several days suddenly seems broken. So when a solution is found, you can relax and let all that anger and frustration go. Honestly, I would have said it the same way if I didn’t (somewhat) understand how facepunch worked. Kudos :smile:

when i open the notepad .vmf (mine is rp_NewTown_1.vmf) it only has this line in it:
{“Constraints”:,“Entities”:} i cant open an others, i do have a very old backup i forgot about, so its usless

If I reset the game configuration does that mean all my lately added data in my usermod folder will be lost? So do I have to make a back-up before doing this?