Hammer Editor error for Garry's Mod.

I keep getting this error. I heard its from the steampipe conversion. I havent mapped in a long time but i went to try to and I got this awful error whenever i try to create a new map. Does anyone know how to fix it?

I’m trying to make a Garry’s Mod map for the Source MP engine btw.

Are you using Source SDK launcher via Steam? Because that method is obsolete, you launch via game/bin.

This is just my opinion, but I’d use the Ep2 or CSS configuration instead of creating a custom one, you can change the map path to automatically copy the bsp to your Garry’s Mod folder; it’s much easier.

I didnt know that, Thanks! I’ll try it out and see if I can get it to work. And yes, I was using the Source SDK launcher

[editline]10th November 2013[/editline]

Once again another error. It gives me this error:

.

I used the counter strike source hammer… I switched my game directory to:

$SteamUserDir\GarrysMod\garrysmod
I also tried: $SteamUserDir\GarrysMod\

Game info.txt seems to be here: $SteamUserDir\GarrysMod\garrysmod.

Scratch all that. Fixed! Thanks man. Happy mapping.

how did you fix it? I am getting the same problem.
thanks

Need a fix for this aswell, except my friend is getting the same thing even if he tries to open through the bin folder.

Download Source SDK 2013 Multiplayer and use Hammer from there. You might wanna keep the old Source SDK around if you want to use propper (0.31), but otherwise you can get rid of it.

Solution:

use half life 2 configurations and set these options:

create somewhere in your computer a folder for the vmf files
change the vmf save location to that folder
in build programs tab do:
change the compiled map directory to gmod maps directory

PROFIT!!!

For all who still need a fix, use the CSS hammer: Steam\SteamApps\common\Counter-Strike Source\bin\hammer.exe .

I think thats what i did to fix it anyway…