Hammer Editor "Failed to load default scheme"

So I’m trying to open up the Hammer editor and this pops up.

http://i.snag.gy/N03G0.jpg

I looked up the problem and tried troubleshooting everything but nothing seems to work. Is there one final workaround or am I screwed? I’m not sure if I set it up the wrong way or what, who knows. Sorry for the novice question, and any help would be appreciated!

Have you tried this? https://developer.valvesoftware.com/wiki/Failed_to_load_the_default_scheme_file

That was one of the first places I went to and it didn’t work. Either the version I got isn’t the same as the one they’re talking about (the part where it mentions “steam/steamapps/common/gamename/bin”, my files doesn’t have a “gamename” or any games in it for that matter) or I’ve got a jinx.

Source Multi Tool is your answer I believe:

http://forum.facepunch.com/showthread.php?t=1327883

Also, next time please post in the Mapping Question Megathread instead of creating a new thread. This question has been asked many times.

Alright, I’ll be sure to try the link and thanks for pointing me in the right direction. Sorry for not seeing the mapping megathread.

Or the search tool

The search tool is awful

are you launching from source sdk or the game’s bin directory?