Hammer Editor problem + 2 questions

Hey guys i was using hammer edit it worked fine and decide to stop working for no reason :confused:

I just tryed to save my testing map and now it dont want to compile my map this is so wierd

I am using 2009 engine set for Hl2

There is the Error msg

Loading c: \ program files (x86) \ steam \ steamapps \ pac0master \ sourcesdk_content \ hl2 \ mapsrc \ PoolTest3.bsp
Error opening c: \ program files (x86) \ steam \ steamapps \ pac0master \ sourcesdk_content \ hl2 \ mapsrc \ PoolTest3.bsp

** Executing …
** Command: Copy File
** Parameters: “C: \ Program Files (x86) \ Steam \ SteamApps \ pac0master \ sourcesdk_content \ hl2 \ mapsrc \ PoolTest3.bsp” "c: \ program files (x86) \ steam \ steamapps \ pac0master \ garrysmod \ garrysmod \ maps \ PoolTest3.bsp "

The command failed. Reported the Windows error:
“The specified file is not found.”

But 5 minute later everything worked fine i just saved my file with a different name cause it was not saving correctly (no change on the last name)

When i save it on the other name like pooltest2 it work but there is no change at all on the map :open_mouth:

What should i do

Ive tryed

Portal
Hl2 Ep2
Hl2 Ep1
Hl2

Dont have any other :confused:


question 1


i found a tutorial on youtube that show how to setup hamer editor
For Gmod … everything worked fine but i got the same thing happened when i was trying to compile the map to bsp
So now im only working on Hl2

Did the same things and got the error when saving


Question 2


How do i add Custom Texture/prop/everything to the Hammer Editor ??

I want to create my own texture and having more props to create better maps.
how do i add all theres things ?

Don’t bother with compiling into gmod, the setup is awkward and can mess things up. Just work in one of the games, such as ep2.

Custom items do not make for better maps. It is the skill of the person making it that makes better maps. Custom items go in their respective directories in the files of the game you are making in. So models go in models, materials go in materials.

Skipping Problem because what. (Are you trying to load BSPs into hammer? Are you trying to run a bsp that’s in your SDKcontent folder in game? what? why are you saving and opening shit from your SDK content folder)

1:

What Phoenix said, just map as if your doing it for CS:S or EP2.

2:

You can add custom materials and models for use in hammer simply by adding them to the game directory for the game you’re mapping in. (If you’re using the CS:S version of hammer, add them to your counter-strike source/Cstrike/ folder.

However you should back up any custom content you use to another folder because after you compile the map, you will have to use Pakrat (or similar) to add the custom files to the BSP.

He is making maps/loading vmfs into hammer then trying to compile.

Paking a file into the map will not remove it from the materials folder.

The big problem is im trying to compile my VMF file into a Bsp it worked the last time i did it and now for unknow reason it dont … i did not changed anything , just modding my map

When the compile options come up, set everything to normal.

Alway Set to normal

[editline]19th December 2011[/editline]

oh yeah my second question was about how to add custom texture to the editor i mean … i seen alots of maps ive downloaded like Big City that came with custom texture How to i add my own ?

[editline]19th December 2011[/editline]

Oh i got this error msg tho —

Can’t load c:\program files (x86)\steam\steamapps\pac0master\sourcesdk\bin\orangebox\bin\filesystem_steam.dll.

Have you run ep2 since the last install before mapping?

And that is how you add customs to the editor, place them in their folders, they will appear next time you load hammer.

Nah i was only running Hammer Editor On Hl2

Must of time i lets Gmod running and type in the console to Load the new map, after saving it ofc

but now it just decide to dont save it :confused: i did nothing different than what im doing … CTRL + S for saving the vmf and F9 for compiling to bsp (run map)

everything to Normal and NOT runing the game checked

Probably something wrong with your setup. I usually don’t bother with a gmod setup, as its awkwardness.

not my set up … it was working one hours ago :confused: and i was not on the Gmod setup … i was on Hl2, same for all the map i made i just tryed to save some change to my map and … not working

i dont know why

What was the change?

Just added 2 button in the map and a Fonc_movelinear to water

i tryed to compile other map like my Saw trap one … cant

so its hammer who bugged out

[editline]19th December 2011[/editline]

Lol wtf i just Turn of my computer for an hour and It work again :confused:

I just tryed on one of my map and it worked fine

Use func_water_analog for water, not movelinear.

Moving water also needs to be given a cheap texture.

Yeah but it’s easier to have everything you’re planning to pak in a seperate location so you can just use those instead of selecting them all out of the folder, and so that you don’t pak extras because the person paking is too lazy to remember/figure out which specific textures they used.

If you use vide, it detects which ones you used and paks them for you.

link?

Edit:

NVM found it on the encyclopedia, thanks.

For Gmod try Episode 2 instead of Just hl2 or DON’T MAP FOR GMOD use ep2 to map your stuff!