Hammer Editor Random Compile Issue

Hello Facepunch,

To start off before I go into this post, I would like to say that the map that I am editing, rp_venator_v3, falls under open source, therefore I am free to edit what I please. Anyways now to the issue.

I was creating a new room in the map, not long after I finished fixing any bad area portal brushes on the map. I wanted to compile the map and give it a little test to see how things were going, the map compiled, but in game all of the area portals were messed up. They were working a previous compile, so I have no idea why. Here is


**** leaked ****
Entity infodecal (-5214.58 -1952.86 -2.30) leaked!

FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3704.0 3072.0 110.5)
Leaf 0 contents: CONTENTS_SOLID 
Leaf 1 contents: 
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
Candidate brush IDs: 


FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3904.0 3072.0 110.5)
Leaf 0 contents: CONTENTS_SOLID 
Leaf 1 contents: 
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
Candidate brush IDs: 


FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3384.0 3072.0 110.5)
Leaf 0 contents: CONTENTS_SOLID 
Leaf 1 contents: 
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
Candidate brush IDs: 


FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3584.0 4096.0 110.5)
Leaf 0 contents: 
Leaf 1 contents: CONTENTS_SOLID 
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
Candidate brush IDs: 


FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (4096.0 3584.0 110.5)
Leaf 0 contents: 
Leaf 1 contents: CONTENTS_SOLID 
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
Candidate brush IDs: 


FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2560.0 4096.0 110.5)
Leaf 0 contents: 
Leaf 1 contents: CONTENTS_SOLID 
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
Candidate brush IDs: 


FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (1536.0 4096.0 110.5)
Leaf 0 contents: 
Leaf 1 contents: CONTENTS_SOLID 
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
Candidate brush IDs: 


FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2560.0 2048.0 110.5)
Leaf 0 contents: CONTENTS_SOLID 
Leaf 1 contents: 
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
Candidate brush IDs: 

*** Suppressing further FindPortalSide errors.... ***
Processing areas...
Brush 10905: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11423: areaportal brush doesn't touch two areas

Brush 11416: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11416: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11416: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11416: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11423: areaportal brush doesn't touch two areas

Brush 11416: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11416: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11416: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11416: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11669: areaportal brush doesn't touch two areas

Brush 11669: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11662: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11662: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas

Brush 11479: areaportal brush doesn't touch two areas
done (0)
Building Faces...done (0)
Chop Details...done (1)
Find Visible Detail Sides...
Merged 1050 detail faces...done (1)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
   skybox/galaxy*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
   skybox/galaxy*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (1) (790118 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 4054 texinfos to 2064
Reduced 113 texdatas to 93 (2832 bytes to 1885)
Writing C:\Users\User\Desktop\Mapping\rp_venator_v3\recover\rp_venator_v4_d_d.bsp
2 seconds elapsed

If you have any idea what caused it, please let me know. I glanced over it to see what could have happened, and what I saw were a lot of brushes not connecting, yet I know that’s impossible because I fixed all the area portals not too long ago. Thank you for your help!
-Chroma

[editline]11th December 2016[/editline]

UPDATE I seemed to have fixed the issue. A setting was turned on and only half the map compiled.

[editline]11th December 2016[/editline]

If a moderator could lock this post that would be fantastic, as it has been resolved. Thank you.

Even if it seem you found the solution, the problem was right at the top of the log:

“**** leaked ****
Entity infodecal (-5214.58 -1952.86 -2.30) leaked”

When there is a leak, areaportals cant work correctly.
So i hope you fixed it using the PointFile

The issue was that only half of the map loaded, therefore a lot of area portals had leaks.

And when I say half, I literally mean only half the map compiled.