Hammer Help!

Every time I try selecting a wall or something it selects whatever is behind it and it’s getting annoying, anyone know how to fix it?

Select objects in the 3D viewport.

That’s what I’m doing but it just selects the wall behind it.
But thx anyway.

Tools / Options / 3D views

Uncheck Reverse selection order.

Thanks a lot!! =D