Hammer is lagging like crap.

Well, the title says it all. Hammer is lagging so hard it is rendered unusable. (see what I did there, rendered!! HAHAHA puns are stupid) But here are my specs:

OS: Windows 8 Enterprise
Processor: 3GHz AMD A8-3870 4 CPUs
RAM: 16 GB

You’ve probably accidentally enabled radius culling, hotkey C.

Thanks, it cleared up the lag! :dance:

I hate that shit!

thank you your a god. i had this problem today was really frustrating, but yes i just press c and its fine thanks again