Hammer is severely glitched. Any Ideas on how to fix it?

Don’t you just hate it when hammer glitches on you? And no matter how many times you reinstall it and delete the folders of it it just doesn’t go away? Well I was hoping someone could help me with a certain glitch that I got when I accidentally ran Hammer using Half-Life 2 Episode 1 as the source game while Episode 1 was doing some sort of file verification automatically. It really messed hammer up.

When I looked at the 3D and 2D views I saw just a light beige wire frame textures where my brushes and models and such should be. Also, the grid was completely gone in 2D view, as were my brushes. I decided to use Episode 2 as the source game to run hammer and it worked…actually, it didn’t. Any models and brushes turned black if I went like 10 meters away from them and the grid was still gone. I decided to save my VMF’s on my desktop and delete all of the source SDK folders then delete local files via Steam. After it re-downloaded everything, same thing. No grid and a light beige wire frame for episode 1. I tried verifying the tool cache and defragmenting it but nothing worked. This sucks. I do have many people just waiting for my map to be released and some requests I need to do. I can’t just stop map-making because of a little glitch. I’m sure someone out there knows what the heck is wrong with Hammer, and if you’re out there. PLEASE HELP ME!

Thank you all for reading this. Post any, and I mean ANY suggestions in reply to this thread. Please you guys?

PICS OF HAMMER:

If I use Episode 2:

http://img198.imageshack.us/img198/6025/hamm1.jpg

If I use Episode 1:

http://img189.imageshack.us/img189/7865/hamm2.jpg

Use source engine 2009.

I get this aswell but only when i use source engine 2009 try 2007 or 2006 works for me.

All of the engines are messed. I explained that. Episode two is 2007 engine.

ITs different for some people, like me ep2 doesnt work in source 2007 but works fine in source 2009.

Hammer only works with the 2006 engine :frowning: Even though I own ep2 engine!

Valve seems to like to break hammer.

It’s probably become a sport to them now!

Ep2 hammer works just fine under Source 2009

But for some, such as myself, it does not appear on the source 2009 list.

Add it manually.

How can you do that?! That might actually fix my problem!

On sourcesdk switch the engine to 2009, then follow this:

http://www.facepunch.com/showpost.php?p=22185516&postcount=10

Replace garrysmod with half-life 2 episode two.