Hammer not reading certain textures?

This is strange, I get back to mapping recently and reload my games and boot up Hammer, and it seems to not be reading some textures:

It’s even gone so far as to not read shadertest/SHADER5 (the Gordon Freeman stained-glass).
I’ve refreshed the SDK, reset game settings, etc.
Can anyone help me out?

Oh, and yes I loaded the map using the correct configuration (Half Life 2 Episode 2).

Well… do you actually have the texture that that brush is using in your materials folder…?

It’s a missing texture from ep2.
Are you mapping for ep2?

I’d imagine so, but even then it’s reading the ep2 GCF, these are default textures.

Yes.

Oh, it’s most likely because it’s a model texture.
Because now, you can’t browse model textures, but some time ago you could.
so you must have saved the map back from when you could use model textures.

It was quite a while ago, so yes. Is there any way to browse the model textures now?

No… DON’T USE THEM. They arn’t desined for use on brushes.

I’m using them for out-of-reach areas and skybox brushes, they worked fine there.

No… They don’t. They will flicker. It uses the wrong shader type.

Problem is sometimes the model version of a texture is the only version of a certain texture you want. (Then again you could probably just GCFScape it out and change the shader)

Yeah, I couldn’t find a good shingle texture, this one worked fantastically.

I know that very well, but that doesn’t apply to all textures and certainly not the ones I used.