Hammer not working properly at all?

Ever since the new TF2/HL2:DM update hammer has been completely broken for me.
I see props that I used become huge and appear everywhere, and some props (Like a monitor) I’ll only see a minor bit of the model.
Can’t click anything, can’t zoom out in the grid(Completely broken) fully and zooming in and everything will disappear. clicking something won’t highlight at all so I won’t be able to move the brush either.
Anyone else experiencing this?

I have the same problem; it seems to be something to do with the move to Gmod 13 and some snooping around tells me it’s something to do with running hammer through the wrong engine which makes sense because it’s built on Garry’s own version of source or something?
I have no grid, I can’t click anything, and I can only see my brushes, not entities.
I tried refreshing content/ resetting config and making new gmod configuration but the problem persists.

Pfft, right.

SDK gets broken with TF2 updates constantly.

It amazes me that they obviously still don’t have a tools tester.

I did offer…

I have the same problem, I was going to experiment with the new “env_skypaint” entity. But when I started Hammer, I noticed the grid was oversized, I couldn’t zoom out to regular size, very strange

So do we just wait until this is fixed or do we have to do something about it?
The only time I have hammer inspiration in months and this happens!

Well I could devise a workaround, IF somebody has the un-updated files, I ran into a similar issue mapping for a game when it was broken for like 6 months. We simply got our hands on the un-updated files, ran source sdk, ran a batch file that copied the files over the updated ones, then ran hammer. Kinda hacky, but it worked. So if anyone has a non-internet connected computer/HD with the old sdk files on it, zip em up and upload em!

EDIT- the old fix is here, wont work without the newer files though: https://dl.dropbox.com/u/17700073/sdk_fixer.zip

After looking around, Valve completely broke TF2,DOD:S and HL2:DM SDK so you’re going to be forced to make the maps on HL2/EP2.

Don’t have hl2. any other solutions?
Does the old fix thingie work?

No it doesn’t, I just posted it for reference, we need the files from before the tf2 update to make it work.

Somebody found a workaround:

source: http://steamcommunity.com/discussions/forum/17/882964117786770534/

Where does the hammer.exe sit, and how do I launch it with settings?

its in \Steam\steamapps\USERNAME\sourcesdk\bin\orangebox\bin > right click one hammer.exe send to desktop(make a shortcut) > right click the shortcut > properties > at the end of the “target” line add " -dxlevel 80"
So your target line should look like:


"C:\Program Files (x86)\Steam\steamapps\USERNAME\sourcesdk\bin\orangebox\bin\hammer.exe" -dxlevel 80

note- you may need to open source sdk in steam before running the shortcut, or you might get some weird errors.

thank you very much :slight_smile:

[editline]29th October 2012[/editline]

Cant browse for props… other than that, works fine

I appreciate the help too guys thanks for the workarounds.

Its fixed

HL2:DM still isn’t fixed though :frowning:

Sadly it isn’t yet fixed for me.
I map for Garry’s Mod though I can’t get any other engines or configurations to work either.

Yeah, it’s not fixed for me either.

I tried the ‘-dxlevel 80’ thing and it caused my Hammer to freeze up every time. There’s something to it though because it seemingly fixed the problem I was having with the 2D panes basically scrambling the vertices of the structures. I really wish Valve would stop breaking the tools. I’d really like to convert a single player map I made into a deathmatch map.

I posted a request for help over on the Valve User’s Forum as well, no answer so far. I guess we have to wait for Valve to fix the problem they caused. I’ll just keep making single player maps to amuse myself 'til HL2:DM SDK gets fixed.