Hammer stopped working

Hey, what’s up you all

My hammer just recently stopped working. Two days ago I received an update for CSS telling me it needed to change the content so it would be more efficient. Something along those lines.
So I accepted, there was no choice. This is what happened when I tried to load up hammer after:

Then when I click ‘Run Anyway’ I get this:

What I’ve already tried to do:

Refresh SDK content
Reset game configurations
Reinstall Source SDK
Reinstall CSS

All to no avail. I would appreciate it if any of you can help me with this issue. Thanks in advance.

[editline]18th April 2013[/editline]

I think I find the source of the problem.

As you can see in the second screenshot the directory is steam\steamapps\username\counter-strike source\cstrike, but steam does not install the game to that directory anymore instead it is now in steam\steamapps\common\counter-strike source. Source SDK however still uses the old path. Wonder how to fix this.

[editline]18th April 2013[/editline]

Okay, I just read something on the Steam forums, apparently they are releasing new SDK’s in the next week or two.

Yeah. I’m getting it too.

Indeed, they’re releasing new SDK’s within the next two weeks. Not sure why not more people are experiencing this as it’s a global update to the way the content system works for some steam games.

So yeah, 1.5 month later and they still haven’t fixed it. Is anyone else experiencing this?

Go to your games-library on steam, and participate in the beta for CS:S called “sdktools_beta” (I think thats what it was) Wait for the beta/updatethingy to download, and launch “hammer.exe” from
steam/steamapps/common/counterstriksource/bin

Thanks a lot, that worked!

Or you can go to


C:\Program Files (x86)\Steam\steamapps\common\Counter-Strike Source\bin

and launch hammer.exe from there without having to DL that beta thing.