HAMMER •• Untextured Custom Model

Now that I’ve got the bone rigging done on my model, I’ve exported the still model as an idle.smd, written a qc file for it, and compiled it through Crowbar.
I’m trying to get it into HAMMER so I can make sure that the basic model works before I go back to make the other animations.
I’m setting up the model for a Garry’s Mod map. First off, I have set up Garry’s Mod through Source SDK 2013 Multiplayer, which has included the assets for HL2, HL2 Multiplayer, and Garry’s Mod.
When I compile the base model, I transfer the five output files (mdl, phys, vtx, etc.) to Source SDK Base 2013 Multiplayer\hl2\models\Test folder. When I enter HAMMER and throw down a prop_dynamic entity and look up the model, it registers. The problem I’m having is that I’ve placed the materials into Source SDK Base 2013 Multiplayer\hl2\materials\models\Test folder (VMT and VTF file), but when I reload HAMMER, the model is still pink and black…

as you can see.

Here is the QC file that I used to compile my base model.



$modelname	"Test/Test.mdl"
$body mybody	"reference.smd"
$staticprop
$surfaceprop	antlionflesh
$cdmaterials	"models/Test"

$sequence idle	"idle.smd" // no animation wanted, so re-using the reference mesh


I know there is no collision model included atm, please don’t nitpick about that.

Here is the VMT coding I used for the texture files.



"VertexlitGeneric"
{
	"$basetexture" "models/Test/Test"
	"$translucent" 1
}


What’s the name of your material in blender? It needs to have the same name as the vmt before exporting.

use hlmv for checking. you can use F5 to reload it while tesing. make sure the basetexture of the vmt points to the correct vtf file.

First off, thank you Midkey for your advice. That turned out to be the problem. The model is now fully textured in HAMMER…
Well, not exactly.

Now that I got a better look at it in HAMMER with its texture applied, I noticed something horribly wrong.
In Blender, the exterior of the belly of my model is textured as you can see below.

However, when I imported the model into HAMMER, only the interior of the belly was textured.

Anyone know what could be causing this?

looks like flipped face normals or something.

in blender press ‘n’ and enable backface culling in the render options. then goto toolbar uv and flip direction or recalculate normals.

I enabled BackFace Culling, although it was under the Shader category instead of Render.
This made the model in Blender appear as it does in HAMMER, with the exterior of the belly invisible.

I’m a little confused with your second recommendation, though. Do you mean go into the UV viewport and use the options there to flip the direction or recalculate normals? I went into that viewport and looked around but I can’t find anything in the toolbar that says “flip direction” or “recalculate normals”.

Thanks, that resolved the issue.