Hammer Visual Error

Hello Facepunch. This is my first time posting, so I apologize if this is in the wrong section, but I really need help.

The problem: Hammer is giving me a horribly annoying visual error, and I have done literally all I can think of (or google) to fix it.

You can find a video HERE: http://www.youtube.com/watch?v=KkQHg3gfR6Y which shows some of the errors.

At 0:05-0:30 you see the first problem: In 2d view, when I click, the view zooms in, and to get it back to normal, I have to click outside the box, then put the cursor back inside the view
At 0:32-1:20 you see the second problem: In 3d view, I can’t see textures. No matter where I looked, I could only (rarely) see the outlines of the boxes. You can see the outlines at 1:25-1:31
At 2:25-2:33 you see the third problem: In 3d view on an existing map, it is in a very skewed and zoomed in view. Also, objects exit the view before they should.
At 2:34-2:2:43 you see the fourth problem: When you move the mouse between views, it flickers between skewed and normal.

Things I have tried:

  1. Uninstalling all source games I have (CS:S, Both L4Ds, Portal 2, and TF2)
  2. Uninstalling all Source content (Source SDK, L4D (and Beta) authoring tools, Source (2007) Dedicated Server, Source SDK Base (2006 & 2007), Source SDK 2013 Multiplayer and Singleplayer, Source Film Maker)
  3. Reinstalling in the orders: Game first, Source second, and then other way around
  4. Changing all SDK settings to work with Valve’s new file locations
  5. Did all the stuff with gameinfo.txts
  6. Tried launching hammer from VBCT
  7. Used hammer.exe separate from the SDK launcher
  8. Opened as administrator
  9. Name a solution on the internet, I’ve tried it

If anyone here has had this problem, or knows how to solve it, please help me! I’ve been Hammer free since 2013. (Oh God…)

Another problem just found: When using any tool, whatever it’s supposed to do is offset. Let’s say, using the entity tool, I click at (0,0). The tool places an entity at (5,-2) Any fix for THIS?

If you think this belongs in the Mapping Question Megathread, you are wrong! “If you have any mapping-related problems” This is a problem with Hammer, not a problem with map making.

Theres no video.

Whoops, must have removed the hyperlink. Adding it in separately now

Well considering you need hammer to make maps.

Are you launching via source sdk or are you launching from the game bin directory (e.g. common\Half-Life 2\bin\hammer.exe)

Currently using common\Team Fortress 2\bin\hammer.exe However, the same happens from SDK. I’ve been advised not to use it, so I launch from the directory.

My point was that mapmaking itself works perfectly fine, and I have no trouble other than these errors. (Also, I didn’t want to get banned on my first post.)

What kind of computer do you have?

Ah, thinking it may be a graphics processor problem? I have an Asus G74sx. I read somewhere about a kind of similar problem where they had to disable their graphics processor to use hammer. On another thing I read, the person also had GeForce graphics card like me, and had a similar error.

Have you tried updating your drivers?

Naah, you can use notepad.exe to make maps :downs:

Using official drivers on a dual graphics laptop is the quickest way to fuck stuff up worse than it already is. If the OP wants to try driver updates, I suggest going to the laptop manufacturers website and use their custom driver package.

Also, Hammer uses video settings for the game it’s currently configured to make maps for. If you’re using the TF2 configuration, try messing with the video settings in TF2 (set all settings to low in the advanced menu, turn off multi-core rendering, etc.) Sometimes messing with the game’s video settings fixes weird rendering problems.

Thanks for responding. I will look into your suggestions and get back to you later

Currently up to date

I did both of these things. Neither changed anything. Any other ideas?

Have you tryed using the CS:S hammer? I use the CS:S hammer since for me non of the rest work.

Doing this now. I get an error though.

http://a.pomf.se/tcuelj.PNG

Hey, you could delete the Hammer key in the Register Editor. (I’ll not take any responsibility for any damage)

Note: This will reset all your Hammer settings. (Not any personal files.)

  1. Press Windows Button+R or find the “Run” menu.
  2. Type in “regedit” and press OK. (Ignore the quotes)
  3. Go into HKEY_CURRENT_USER/Software/Valve
  4. Delete the “Hammer” note/folder.

This has fixed many of my issues with the Hammer editor.

Would it suffice to rename it? “Hamner” for example

To be on the safe side yea, I guess. But I haven’t got any issues with Hammer not “reinstalling” itself.

Damn. It still didn’t fix the problem. I’ll try Hammer for CS:S now

Update: It didn’t work.

I’m going to try an older version of hammer.

Update: That didn’t work either. Does someone who has time to waste want to add me on steam and go over file locations and such? LuLz. The Hatter at http://www.steamcommunity.com/id/BrokenSource/

Are you trying to make a TF2 map?

At this point I don’t care anymore. I just want some version of hammer to work. I’d like to make either TF2 maps or CS:S maps again, but can’t.

Go into the common folder and find the ‘Gameconfig.txt’ in the bin folder with the hammer.exe in it, and paste it here?

Probably nothing to do with the visual error you are getting but this is Valve remember.