Hammer will not launch, missing DLL

So, im not too sure on how widespread of an issue this is. but an update on steam has rendered my hammer unoperational.

While launching (from the folder, not through SDK) the following error appears:
The program can’t start because steam_api.dll is missing from your computer. Try reinstalling the program to fix this problem.

I know sickness is also getting the problem, how about the rest of you out there? Have you encountered this issue, maybe even fixed it? If so, where did you obtain this dll file, and did that resolve the problem? I don’t trust these websites out there that say they have this dll file.

Fix: Verify HL2 Files.

I am also having this issue. Seems pretty wide spread.

I had this issue, I fixed by doing “Verify integrity of game cache”, it fixed it for me, don’t know about others, but I suggest you try it

I verified my HL2 files and it fixed it.

I’m in the process of verifying my HL2 & EP2 game files. Hope this fixes it.

edit

Yup, verifying HL2 definitely fixes the problem!

Thread can be closed

This worked for me too, thanks vrej. Perhaps put the fix in the OP?