Hammer wont auto-start map after compile

So after that probably confusing title, allow me to explain a little. I have been working on this map for a little while, everything is going great. All of the sudden hammer Editor decides to stop running the maps after they compile. Like, Half Life 2:EP2 starts up, but it is just the startup menu, not the map. I thought it was a problem with my map at first, a little research I did on the steam forums suggested it was a Leak, which it was not. I took the BSP file produced after compiling and ran it in Garrysmod, it started up without a problem.



** Executing...
** Command: "c:\program files (x86)\steam\steamapps\mjb559\sourcesdk\bin\orangebox\bin\vbsp.exe"
** Parameters: -game "c:\program files (x86)\steam\steamapps\mjb559\half-life 2 episode two\ep2" "C:\Users\Jake Brown\Desktop\Dream.vmf"

Valve Software - vbsp.exe (Jul  7 2010)
2 threads
materialPath: c:\program files (x86)\steam\steamapps\mjb559\half-life 2 episode two\ep2\materials
Loading C:\Users\Jake Brown\Desktop\Dream.vmf
Could not locate 'GameData' key in c:\program files (x86)\steam\steamapps\mjb559\half-life 2 episode two\ep2\gameinfo.txt
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
Processing areas...done (0)
Building Faces...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
writing C:\Users\Jake Brown\Desktop\Dream.prt...Building visibility clusters...
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (0) (12591 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 13 texinfos to 7
Reduced 5 texdatas to 3 (152 bytes to 68)
Writing C:\Users\Jake Brown\Desktop\Dream.bsp
0 seconds elapsed

** Executing...
** Command: "c:\program files (x86)\steam\steamapps\mjb559\sourcesdk\bin\orangebox\bin\vvis.exe"
** Parameters: -game "c:\program files (x86)\steam\steamapps\mjb559\half-life 2 episode two\ep2" "C:\Users\Jake Brown\Desktop\Dream"

Valve Software - vvis.exe (Jul  7 2010)
2 threads
reading c:\users\jake brown\desktop\Dream.bsp
reading c:\users\jake brown\desktop\Dream.prt
 123 portalclusters
 430 numportals
BasePortalVis:       0...1...2...3...4...5...6...7...8...9...10 (0)
PortalFlow:          0...1...2...3...4...5...6...7...8...9...10 (1)
Optimized: 0 visible clusters (0.00%)
Total clusters visible: 14859
Average clusters visible: 120
Building PAS...
Average clusters audible: 123
visdatasize:4924  compressed from 3936
writing c:\users\jake brown\desktop\Dream.bsp
1 second elapsed

** Executing...
** Command: "c:\program files (x86)\steam\steamapps\mjb559\sourcesdk\bin\orangebox\bin\vrad.exe"
** Parameters:  -game "c:\program files (x86)\steam\steamapps\mjb559\half-life 2 episode two\ep2" -noextra "C:\Users\Jake Brown\Desktop\Dream"

Valve Software - vrad.exe SSE (Jul  7 2010)

      Valve Radiosity Simulator     
2 threads
[Reading texlights from 'lights.rad']
[48 texlights parsed from 'lights.rad']

Loading c:\users\jake brown\desktop\Dream.bsp
Setting up ray-trace acceleration structure... Done (0.00 seconds)
163 faces
20561 square feet [2960785.75 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
163 patches before subdivision
1513 patches after subdivision
0 direct lights
BuildFacelights:     0...1...2...3...4...5...6...7...8...9...10 (0)
BuildVisLeafs:       0...1...2...3...4...5...6...7...8...9...10 (1)
transfers 59981, max 219
transfer lists:   0.5 megs
GatherLight:         0...1...2...3...4...5...6...7...8...9...10 (0)
	Bounce #1 added RGB(0, 0, 0)
Build Patch/Sample Hash Table(s).....Done<0.0014 sec>
FinalLightFace:      0...1...2...3...4...5...6...7...8...9...10 (0)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (1)
Writing leaf ambient...done
Ready to Finish

Object names       Objects/Maxobjs  Memory / Maxmem  Fullness 
------------       ---------------  ---------------  -------- 
models                   1/1024           48/49152    ( 0.1%) 
brushes                 27/8192          324/98304    ( 0.3%) 
brushsides             270/65536        2160/524288   ( 0.4%) 
planes                 258/65536        5160/1310720  ( 0.4%) 
vertexes               221/65536        2652/786432   ( 0.3%) 
nodes                  158/65536        5056/2097152  ( 0.2%) 
texinfos                 7/12288         504/884736   ( 0.1%) 
texdata                  3/2048           96/65536    ( 0.1%) 
dispinfos                0/0               0/0        ( 0.0%) 
disp_verts               0/0               0/0        ( 0.0%) 
disp_tris                0/0               0/0        ( 0.0%) 
disp_lmsamples           0/0               0/0        ( 0.0%) 
faces                  163/65536        9128/3670016  ( 0.2%) 
hdr faces                0/65536           0/3670016  ( 0.0%) 
origfaces               99/65536        5544/3670016  ( 0.2%) 
leaves                 160/65536        5120/2097152  ( 0.2%) 
leaffaces              220/65536         440/131072   ( 0.3%) 
leafbrushes             59/65536         118/131072   ( 0.1%) 
areas                    2/256            16/2048     ( 0.8%) 
surfedges             1220/512000       4880/2048000  ( 0.2%) 
edges                  744/256000       2976/1024000  ( 0.3%) 
LDR worldlights          0/8192            0/720896   ( 0.0%) 
HDR worldlights          0/8192            0/720896   ( 0.0%) 
leafwaterdata            0/32768           0/393216   ( 0.0%) 
waterstrips              2/32768          20/327680   ( 0.0%) 
waterverts               0/65536           0/786432   ( 0.0%) 
waterindices            30/65536          60/131072   ( 0.0%) 
cubemapsamples           0/1024            0/16384    ( 0.0%) 
overlays                 0/512             0/180224   ( 0.0%) 
LDR lightdata         [variable]       72984/0        ( 0.0%) 
HDR lightdata         [variable]           0/0        ( 0.0%) 
visdata               [variable]        4924/16777216 ( 0.0%) 
entdata               [variable]         323/393216   ( 0.1%) 
LDR ambient table      160/65536         640/262144   ( 0.2%) 
HDR ambient table      160/65536         640/262144   ( 0.2%) 
LDR leaf ambient       123/65536        3444/1835008  ( 0.2%) 
HDR leaf ambient       160/65536        4480/1835008  ( 0.2%) 
occluders                0/0               0/0        ( 0.0%) 
occluder polygons        0/0               0/0        ( 0.0%) 
occluder vert ind        0/0               0/0        ( 0.0%) 
detail props          [variable]           1/12       ( 8.3%) 
static props          [variable]           1/12       ( 8.3%) 
pakfile               [variable]      211834/0        ( 0.0%) 
physics               [variable]       12591/4194304  ( 0.3%) 
physics terrain       [variable]           2/1048576  ( 0.0%) 

Level flags = 0

Total triangle count: 438
Writing c:\users\jake brown\desktop\Dream.bsp
2 seconds elapsed

** Executing...
** Command: Copy File
** Parameters: "C:\Users\Jake Brown\Desktop\Dream.bsp" "C:\Users\Jake Brown\Desktop\Dream.bsp"



Any help or suggestions are greatly appreciated, thank you all in advance :).

Is “Don’t run the game after compiling” checked?

Might be obvious, but when you press compile is that little check box that says “Don’t run game after compile” checked?

[editline]1[/editline]

fuck the ninja

http://www.facepunch.com/fp/emoot/ninja.gif

No. The game itself DOES run, the map just doesn’t start. The game will start up, but it is just the normal start up menu.

According the the compile log, you saved the VMF on the desktop, which is where the BSP was created. Try moving the VMF into your HL2:EP2 maps folder, restart hammer, and recompile.

Okay, I will also tell hammer to make that the default directory to save maps to when working with EP2.

EDIT:

SUCCESS :D. Thank you for your help, GameDev, and for the suggestions from the rest of you :).

No problem, good luck with your map.