Hammer's Grid doesn't work

I tried creating a new mod. I want to make a map to test the weapons, but whenever I launch hammer, this happens:

None of the grids move, no matter what I do with them. I can’t place brushes or entities, either. When I first launched it, it said I was missing materials/editor/flatignorez.vmf, so I took that from the HL2 VMF. It fixed it, but I think this is a texture problem.

This looks like an incorrectly made configuration.
You need to own/use the OrangeBox engine for GMod configurations, otherwise you get this, so I’m guessing try the other engine for your mod

You’re using the wrong engine. Try switching between the ep1 and orangebox engine with hammer.

[editline]01:21PM[/editline]
Damn ninja.

[editline]01:21PM[/editline]

Hes making his own mod.

Ninja edit, since I remembered moments after posting :v

I ninja’d a ninja’d edit. :v:
Close enough.

That worked for the first issue, but now I don’'t see any of the weapons in the entity menu. The script files are in sourcemods/test/scripts.

You’ll need to write a custom .fgd if you want them to appear in the entity menu. Otherwise just place them manually with smart edit turned off as weapon_weaponname