Haven't Been able to Play Rust for about a year

So basically this is my issue.

I’ve been playing rust (now rust legacy) since day dot and have had zero problems with it. But ever since the New Rust has been released I have not been able to play as I receive the message Disconnected: Connection Attempt Failed
This has been happening since the release of New Rust

List of things that I’ve tried to fix it with.

  • Verifying Integrity of Game Cache
  • Re-installed Rust (at-least 20x)
  • Re-installed Windows (3x)
  • Add Rust to Firewall
  • Disabled Firewall
  • Disabled Modem Firewall
  • Tried different Ethernet cables
  • Tried Wireless dongle
  • Run as Administrator (XD)
  • Run in DirectX 9 version
  • Run in pre-release beta and debug beta
  • Tried spamming the reconnect button (like 50x)
  • Tried new modem
  • Installed Easy Anti Cheat manually

However I tested rust on my sisters computer and it connected straight away, no problems.
I would really love to get back into rust again but I have no idea how to fix this issue.
If some smart tech geniuses could help me out I would Greatly appreciate it.

Regard Nick

In your files where you have steam installed, go to steamapps\common\rust
Right click on the “Rust” application and “Run as Administrator”

At least that’s how i fixed my disconnection issue.

That happens to me when I try to connect with console.

I simply remove one number from the adress, try connection for intentional failure, then retry the real adress. And it works.

How do I get the ip for the server my friends play on?

[editline]18th April 2016[/editline]

Na it didn’t work

It’s probably irrelevant, but what are your specs?

Specs are key here - you might have to opt-in to the alt dx9 build. I had to until I realised I’d been running on no vid card drivers for like a year. So yeah, make sure your drivers are as up to date as they can be

CPU: i5 4690k
GPU: Asus HD 7970
Mobo: Z97M-PLUS
Ram: 8GB corsair vengence ram 1600mhz
HDD: 1 Tb Black (rust drive)
SSD: 128GB
PSU: 750w Strider Essential (although not relevent)

[editline]18th April 2016[/editline]

I’m Pretty sure their all up to date but i’ll check anyway :slight_smile:

Make sure your computer is selecting your 7970, unity games like to use the onboard Intel graphics which causes a lot of people headaches, try forcing it through your gpus control panel, I’m not sure how to do it with AMD but with nvidia it’s very simple and I would think with AMD it would would be very similar.

For nvidia it’s simply:
Open nvidia control panel
Click on manage 3D settings
Under global settings, Click “Preferred graphics processor” and select your dedicated graphics card.

This forces your PC to always select the dedicated card no matter what game or application you’re running.

I gave it a try but still the same thing :frowning:
Thx anyway :slight_smile:

Any other suggestions because this has bamboozled me. :frowning:

Is your sister’s computer using the same network?

If it is I think it must be some sort of a weird motherboard error because i dont know what else it could even be.

[editline]20th April 2016[/editline]

See if you can find newer drivers for the motherboard’s ethernet thing.

Check the network admin pannel and see if some weird ports are blocked.
You can try to click on “Reset to default” in this same pannel.

Edited:

Oh it’s working on your sister’s computer nvm…
So yeah just try to update all your hardware drivers and stuff…

Edited2:

Try and allow some Rust standard ports like 28015 / 28016 and come back to us

Have you got the windows firewall running? People turn of their firewalls but sometimes forget the windows one.

I did manage to correct this eventually by deleting my config folder from SteamLibrary/SteamApps/common/Rust/cfg , restarting Steam and then Rust. I’m almost sure this is what solved it.

@OP, open rust, press f1, then press system information, does it say it’s using your 7970? Or does it say Intel Graphics?

It shouldn’t matter what GPU it’s running on, the fact that he’s getting to the menu tells me that it initialized the display just fine. Even if it were running on the Intel, it would still run. Just not very well.

Yeah I’ve tried disabling all firewalls and playing it with no effect :frowning:
Thanks anyway

[editline]21st April 2016[/editline]

Well I’ve updated all my drivers to the latest version and was still unable to play.
However I’m not quite sure how you all ports through. IF you could give me a quick run down mabey I could figure it out :slight_smile:

[editline]21st April 2016[/editline]

I updated all my drivers to the latest version yet I still experience the same problem. However
I’m unsure how you allow ports through. IF you could give me a quick run down mabey I could
figure it out.

Opps double reply.

[editline]21st April 2016[/editline]

Na this didn’t work either. What other thing did you try to solve it.
Thanks for the suggestion btw :slight_smile:

So I think its safe to say that my rust is unfix-able :frowning:
Is it possible to get in contact with a Dev though?

try making a new windows user profile and start rust from there.

Nope, didn’t seem to work either :frowning: