Having problems importing a 3D player model into Gmod need help from people who know

Hello guys! I need a little help importing a player model into Gmod

I’ve been trying to get a Xenoblade character into Gmod, in order to do that I’ve been following a tutorial (since I’m NEW to this stuff, a complete noob)
this is the tutorial btw (so you can see where I’m having problems)
https://www.youtube.com/watch?v=aOd4aiW-VTk
(made by an user btw)

THE ACTUAL PROBLEM:

So, I’ve done everything the tutorial says but once I open Gmod the player model won’t even be “chooseable” I mean, not even missing textures or the option showing up and having problems with it, is just that the option won’t show up at all

I think I messed up something although I’m sure I’ve done “exactly” what the tutorial says
here are some screenshots so you guys can see how my folders are set up and how both QC and LUA files are written

.QC
http://i.imgur.com/tdwdaGP.png

.Lua
http://i.imgur.com/0n190rM.png

also I’m not having problems with the textures at the moment (I guess since the 3D model won’t even work lol) but I’ll post these just in case so you can see how the textures are set up
http://i.imgur.com/fldxruU.png

Notice anything strange guys? maybe the 3D model itself was made in the wrong way?
which lead me to this… I know it may be asking a LOT! but can you guys test my 3D model on your machines?

**THE 3d model **(made in 3DS max wich contains the QC file I’ve used)
https://mega.nz/#!wNYAWRII!COM_MpCaJ1SKQdrvYBgIjRyq-CKb40BJ96dXC8ga6R8

and here are the textures I’ve used in these 3 formats: TGA (original textures) vtf and vmt
https://mega.nz/#!VUB0WZqa!HPG1mQFEfxY75v2NLnNeO5Nn1Mxbt6nElmEcm6k wDVk

Here’s how the model should look like (an Image from the actual game the 3D model comes from, it being Xenoblade Chronicles )
http://i.imgur.com/IHpcJ.jpg

thanks a lot if you’ve read this far, I really want this to work so I can move on to make the whole cast playable! and even include a whole map from XENOBLADE!

A MAN CAN DREAM!

please I hate being “that guy” that thinks he’s the center of the world but I would like to know your opinions and thoughts

so I can start all over as soon as possible if I messed up something important T.T

Delete the : at the end of the 5th line and delete the 6th line and see if that helps.

Just tried and it still doesn’t work

Thanks for trying to help :smiley:

Can you post what it looks like in the lua now? It should look exactly like this.
player_manager.AddValidModel( “Dunban”,“models/player/Mios/dunban ver1.mdl” )

that is the only line you need to load it into the player selection screen. You dont need that “Addon by” thing either.
also, personally, I would drop the capital M in Mios in folder and lua. I don’t know if that’s causing an issue since I don’t do that but I do know capitals can cause complications.

I started all over and made all the folders again now with a lua file written like this:

Still doesn’t work :S

I added you, name is autismo

Oh sorry I didn’t notice…thanks!

[editline]9th October 2015[/editline]

KoenLeung is a god

the problem was that the Lua file had spaces on it’s name so I changed it to just “player” like he said and IT WORKED!

and OF COURSE ALSO HUGE THANKS TO YOU SilverBelle

No problem! Happy I could help in anyway. ^^