Having troubles with downloading a map using fast download on my server

I put the map and the materials on my fast download server and on my server. However, when I try to connect to it, it disconnects saying:

“Missing maps maps/freespace_revolution.bsp,
disconnecting”

The map file is in the root of my garrysmod folder on my webhost, which I use for the fast download.

1). add the map to the both sides / Server & FastDL
2). go to your server.cfg (can be found in “root/cfg/”
3). add this line “net_maxfilesize 900” without the quotes

Enjoy

Still not working :s

I guess a disadvantage of a forum is that nobody replies for 5 hours.

Check the following:

Make sure you added a trailing / to the end of the sv_downloadurl address, example sv_downloadurl “http://YourSite.com/garrysmod**/**

Make the files in the garrysmod directory on the web server are world accessible, a good way to check would be to trying a direct download of a file on the web server. (Example - http://yoursite.com/garrysmod/maps/mapname.bsp. If it downloads the permissions are okay, if it fails to download or gives you an error adjust the file permissions.

As stated above increase the net_maxfilesize in your server.cfg

Make sure the files are mirrored correctly.

Local path
garrysmod/maps/mapname.bsp

Path on the web server
http://yoursite.com/garrysmod/maps/mapname.bsp

If your still having problems, I may be able to lend a hand FastDL can be a pain at times. Feel free to add me on Steam or send me a PM. I’d check out the sv_downloadurl wiki page if you have not already, it comes in handy.

Hope this helps.

You take time to build a well-thought out and well-structured post.

I appreciate the effort you put into making sure people get their problems solved. I don’t think I can thank you enough.

Anyways,

I should probably put the map in the maps/map.bsp on my webhost. I’ll post back or PM you on steam if I need further assistance.

Thank you.

I thought that the net_maxfilesize limit was 64 mb…

It is.