Heeelp! "attempt to call field 'Count' (a nil value)", adv dupe and spawning errors

Hey

When I tried to join my server today, I got many errors… a few things didn’t work - for instance respawning. I just respawn when I die, and when I first spawn, I spawn in the middle of the sky (probably coords 0,0,0 of gm_wireconstruct_bna). The Adv Duplicator won’t save anything either… It gives the error
“…ator\lua\weapons\gmod_tool\stools\adv_duplicator.lua:525:bad arguement #2 to ‘min’ (number expected, got nil)”
I took a few confusing screenshots of my server console. Please don’t sue if your brain implodes like mine did :S

Just a little breakdown of this image… It’s the console of my server after a player has joined.

First part is standard errors involving the gatespawner, up until “Error unserialising VTF file”… no clue what that means, it’s always sort of been there. Never caused a problem.

The thing that is new on this image is where it says “attempt to call field ‘Count’ (a nil value)” on the LUA errors near the bottom of the page. Almost all of the major addons give this error, even the kawoosh that the stargates make. And also “Error sending usermessage! Too large!” just after a player connects
E2 also gives the ‘Count’ error when executing ‘postinit’ hook, but the server was still starting - and I couldn’t copy it properly.

http://gserv.lovebf2.co.uk:85/thepunchofface.png

A friend of mine says that it doesn’t know how many players there are. I hope someone can solve this, please D:

another snapshot of the console a little later:

http://gserv.lovebf2.co.uk:85/thefacethatpunches.png

The only thing I installed after the last time the server worked properly was poly_weld. And I reinstalled SolidVotes.
edit: The other thing I’ve recently done is set up the sv_downloadurl in my server configuration. The line looks like this:
“sv_downloadurl” “http://gserv.lovebf2.co.uk:85/garrysmod
Which is… valid… right?

PS: the images above are hosted on the same server as the sv_downloadurl server…

uhm… Bump? O_o

Removing polywelds didn’t work, and disabling prop core didn’t work.
edit: Updating HLDS didn’t work either.

Sorry for the quad-post…

I think I know what caused the problem - but my laptop broke when I tried to restart it, hence you can’t see the images above >_< WinFail Vista :<
I think it’s that I put the SVN for the LUA module of polywelds (queryphys?) in the wrong place (lua\includes\modules\modules) because I didn’t read the destination path it chose properly.
Hopefully I can get my server back once I get an enclosure for this old hard drive.