HELP 3Ds Max UVW Map export Source

I’m trying to make a silenthill map for HL2/Garrysmod and I decided to try out some cinematic physics and put it as a sequence for a model.

I was following this tutorial:

This is my first time using 3Ds Max and compiling for source, I usually use Blender but I don’t know of a way to be able to make a cinematic model export with animation

I did basically the same thing except with a wall of concrete.
When I export it and open it up in Hammer, the Texture is all screwed up. I know it’s using the texture I directed it to use because when I rename the .vtf and .vmt it turns to a pink and black checkerboard
When I open it in the HLMV it doesn’t even show up unless i rename the .vmt and .vtf, then it shows up with the stupid pink black checkerboard.

The tutorial above doesn’t explain how to UVW Map so I searched for another just for UVW Mapping

Here’s how I’m UV mapping my model.

  1. I have my model and the blue marker the animation created, converted the wall to an editable poly (is the conversion necessary?)
    http://img210.imageshack.us/img210/4397/modelmarker.jpg
  2. I go to the material selection box by pressing “M,” click on the little thing next to “diffuse”
    http://img202.imageshack.us/img202/6290/diffusebtn.jpg
  3. I choose bitmap and select my texture, in this case it is “concretewall032a.tga”
    http://img59.imageshack.us/img59/3599/bitmapbtn.jpg http://img519.imageshack.us/img519/4778/bitmapchooser.jpg
  4. I apply the texture to my concrete wall and rename the diffuse map to the name of the texture “concretewall032a”
    http://img237.imageshack.us/img237/3299/maprename.jpg
  5. I add a modifier to it: UVW Unrawp
    http://img6.imageshack.us/img6/7820/unrawpuvw.jpg
  6. I click “Edit” to the right, go to the top for “Mapping,” apply the “Flatten Mapping” choice. I know the map doesn’t fit like puzzle pieces but it works!
    http://img36.imageshack.us/img36/2407/flattenmapping.jpg
    http://img41.imageshack.us/img41/6497/maptile.jpg
  7. I go back to the material selection box by pressing “M” and turn up the tiling so it doesn’t look so bad
    http://img7.imageshack.us/img7/6020/tileset.jpg
  8. From the viewports everything looks ok so I go ahead and use the SMD Export plugin from here:
    SMD Export from Wunderboy
    http://img716.imageshack.us/img716/4318/view1l.jpg
    http://img297.imageshack.us/img297/8558/view2a.jpg
  9. I export as reference first (I use the output .smd for both the $body and the idle $sequence value in the .qc file). Saved as “wall_idle.smd”
  10. I then export it again as a sequence for the animated physics. Saved as “wall_explode.smd”
  11. I export it one last time as a reference for when it’s idle after the explosion. Saved as “wall_explode_idle.smd”

Here’s the QC file I’m using:



$modelname "silenthill\wall.mdl"
$body mybody "wall_idle.smd"
$cdmaterials "models\silenthill"

$sequence idle	"wall_idle.smd" loop fps 1
$sequence explode "wall_explode.smd" fps 30
$sequence explode_idle "wall_explode_idle.smd" loop fps 1


Here’s the .vmt file I’m using for the texture “concretewall032a.vtf”



"LightmappedGeneric"
{
	"$basetexture" "silenthill/concretewall032a"
	"$surfaceprop" "concrete"
	"%keywords" "c17sewers,wasteland"
}


When opened in hammer, the sequences work, but the texture is problematic
http://img12.imageshack.us/img12/3010/hammerwalltexture.jpg
When opened in HLMV, can’t see anything
When the .vtf and .vmts incorporated w/ the model are renamed:

I also tried this on a basic cube. No improvement

If anyone can help, THANKS. I’m pretty sure it’s something stupid that I’m missing

change


"$basetexture" "silenthill/concretewall032a"

to


"$basetexture" "concretewall032a"

Tell me if that works:P

Thanks for your quick reply.
I tried what u said but unfortunately still no change in the texture D:

What’s weird is it had no change to that strange solid pink texture, so there may be sumthing wrong with the .vmt
I shall see what else I can change

Hmm upload the model + texture to mediafire.com and pm me it :stuck_out_tongue: I will take alook (boreD)

Aight so I upped a .zip archive with all the stuff to mediafire.

http://www.mediafire.com/file/mvmmnyztvio/3Ds Max Problem - Silenthill Wall Model.zip

You’ll find the 3DsMax file in there as well as the .qc file and the .smds
The folders correspond to how they would be in the HL2 ROOT folder.

Thanks for u’re help

Also here’s a .bat that just allows me to drag n drop my .qc files to studiomdl
http://www.mediafire.com/file/dey2djm1ryv/run_studiomdl.bat

OK found the problem



"LightmappedGeneric"
{
	"$basetexture" "silenthill/concretewall032a"
	"$surfaceprop" "concrete"
	"%keywords" "c17sewers,wasteland"
} 

to



"LightmappedGeneric"
{
	"$basetexture" "models/silenthill/concretewall032a"
	"$surfaceprop" "concrete"
	"%keywords" "c17sewers,wasteland"
}


Enjoy^^

I tried what you said. It slightly fixed it :S
It produces a strange result. Perhaps it’s the UV Mapping that’s causing the problem, but srsly, it would stretch that much?

http://img15.imageshack.us/img15/3619/hammerwallweirdtexture.jpg

Also when I try to open it in the Half-Life Model Viewer, it shows nothing -.-
*EDIT
I tried ticking the “Illuminate position” and it was showing, just very zoomed out, so after zooming very far in I could see my model, just w/o textures. There were hitboxes, I could see it in wireframe. weird stuff going on here

I know for sure the texture is working cuz when i replace the .vtf used by the model it shows the new image, just very distorted. I’ll mess around with some UVW Mapping in 3Ds Max

[editline]01:26AM[/editline]

Could someone download the .max file I included in the .zip archive above and try exporting and compiling it with their own 3Ds Max and export plugin. It may be the tools I’m using that are problematic.

I’ve found out that the export plugin and the .qc files aren’t disfunctional. I decompiled the advisor .mdl using cannonfodder’s decompiler. Then I imported the reference .smd into 3Ds Max and exported it. I ran my own custom .qc file on it and everything looked good. As soon as I start fooling around with the UVW mapping in 3Ds Max, things start screwing up. I really can’t see what I’m doing wrong.

If anyone could also point me to a really good over-detailed 3ds Max modelling for Source tutorial, I’d be very greatful =D
Edit - sorry for dbl post I meant to put it as an edit

SOLUTION:

I figure out my problem, it was with the .vmts
I had to switch up the “LightmappedGeneric” with “VertexLitGeneric”
I think for models, it has to use vertexlitgeneric? Am I right?

But nevertheless I am content now that I am able to create all that I want. I’ll release the SilentHill map when it’s done.
Thanks to the ppl who contributed.

Here’s the working .vmt



"VertexLitGeneric"
{
	"$basetexture" "models/silenthill/concretewall032a"
	"$surfaceprop" "concrete"
	"%keywords" "c17sewers,wasteland"
}