[Help ASAP!] Missing CS:S Weapon Textures and Etc.

Ok so recently after the new Garry’s Mod update and the new M9K update, I am unable to see the Smoke texture (after explosions), gun casings (they fall out of gun after shots are fired), and all of the CS:S guns and CS:S Weapon Alternatives (ALT TMPs and the like). It just happened and I am sad now as it makes it difficult to raid and etc. on a DarkRP server that I administrate. Please help me ASAP!

Do you have CS:S mounted on your client?

Yes, on the gaming controlled CS:S and TF2 are both ticked, I have restarted GMod many times as well.

[editline]28th May 2014[/editline]

I used to be able to see everything with no errors but they just recently started happening when the new GMod update and the new M9K update came out…

Ok so this morning I went on again to attempt to debug the issue, and found that I can see the grenades, gun shells, and weapons just fine in singleplayer, but it is just not working on the DarkRP server with M9K guns. Plese, I need this fixed urgently!

Hello Billy ,

please make sure your mount.cfg contains no // before the path and double check the path itself to be correct.

If you are on linux then note that the path can not contain capital letters.

Hope this helps !

//
// Use this file to mount additional paths to the filesystem
// DO NOT add a slash to the end of the filename
//

“mountcfg”
{
// “cstrike” “C:\steamcmd\steamapps\common\Counter-Strike Source Dedicated Server\cstrike”
// “tf” “C:\mytf2server f”
}

That is my mount.cfg, what do I need to edit?

Take out the // in front of cstike like he already said.

I did and still errors

Should it be…

//
// Use this file to mount additional paths to the filesystem
// DO NOT add a slash to the end of the filename
//

“mountcfg”
{
“cstrike” “C:\steamcmd\steamapps\common\Counter-Strike Source Dedicated Server\cstrike”
“tf” “C:\mytf2server f”
}

Like that?

you need to replace the path with YOURS

C:\Program Files (x86)\Steam\SteamApps\common\Counter-Strike Source\cstrike

Is that a proper path? That’s my cstrike folder.

Yes. Also, put // back in front of tf.

Did what you said and still errors. I am lost. Help please?

Post your new mount.cfg in


 tags.



//
// Use this file to mount additional paths to the filesystem
// DO NOT add a slash to the end of the filename
//

"mountcfg"
{
	"cstrike"	"C:\Program Files (x86)\Steam\SteamApps\common\Counter-Strike Source\cstrike"
	// "tf"			"C:\mytf2server	f"
}


Ok so I put the // back in front of TF, will I still be able to use TF2 Stuff in-game?

Not on your server. I told you to comment it out because you were using the default path; you can use it if you actually have the content on your computer and you use a valid path.

I made it like you said, but I’m just leaving out TF2. Can you tell me why I am still getting errors?

Post a startup log in


 tags.

Ok so it does work, but it is conflicting with DarkRP itself, like, the gamemode. I can use all weapons in TTT, Sandbox, etc, but DarkRP for me is extremely buggy and will not show them. Do I need to redownload the DarkRP gamemode, maybe?

It’s probably that M9K doesn’t work with DarkRP with the new update. Try using another gun base.