Help | Cant running my gmod server.

this the error :
failed to dlopen /home/gmod/gmod/orangebox/garrysmod/bin/server.so error=/lib/libc.so.6: version `GLIBC_2.7’ not found (required by /home/gmod/gmod/orangebox/garrysmod/bin/server.so)

Before the update the server was working perfect…

thanks for help.

Bump

I have the same problem on My Centos 5 server.
The fact is the last available version of Glibc for centos is 2.5 and garrysmod server is compiled with 2.7
Solutions :

  • Manually installing GLIBC_2.7, might crash your OS. ( don’t do it)
  • recompile server.so with GLIBC_2.5
  • Ask centos to makes a later version of GLIBC than 2.7 available with yum update.

you can give me version of server.so recompile with GLIBC_2.5?

thank you very much!

I don’t have it and my server is stuck as yours.

ohh so what we can do?

Wait for support / bugfix.
Change your OS. :frowning:

Who can recompile server.so with GLIBC_2.5?, garry doesn’t answer to me on twitter.

Garry can. You need to get GLIBC_2.7 on your server, somehow.

Same error here :frowning:
running CentOS Linux 5.6, used to work fine now it don’t.

failed to dlopen /home/garrysmod/orangebox/garrysmod/bin/server.so error=/lib/libc.so.6: version `GLIBC_2.7’ not found (required by /home/garrysmod/orangebox/garrysmod/bin/server.so)

what we can do?

Can anyone please provide an old version of server.so ? (before the latest update).
Garry seems to not care about us.

Far as i know we wont be able to run GarrysMod as long as it needs GLIBC 2.7 as CentOS5 only has GLIBC 2.5, will just have to keep asking Garry for fix.

I tried to send email to garry’s but he’s not respond and i try to talk with him on twitter but he isnt respond in twitter to )=

bump

I’m sure he’ll fix it sooner or later. Just wait it out. (;

GARRY,

Y U NO FIX!?

Don’t think he will fix :frowning:
All he needs to do it make a recompile of server.so for the CentOS GLIBC though…

Unless someone has a older version of server.so anywhere?

I hate to see so many people struggling with CentOS & Gmod. I’ve run into many troubles which have been solved via these very forums. So here is my gift to all those who are running CentOS and can not use GLIBC_2.7:

http://zcowgameservers.com/gmod-serversofix/server.so

This is the server.so from before the change. It works for me on my machines, which are all CentOS 5.x.

For the savvy:
wget http://zcowgameservers.com/gmod-serversofix/server.so

I hope this helps & works for everyone…
Cheers!

BUMP :slight_smile:

This is a real hard issue :frowning: