HELP! Compile error!

i get this error when i try to compile.


** Executing...
** Command: "c:\program files\steam\steamapps\zackcentner\sourcesdk\bin\orangebox\bin\vbsp.exe"
** Parameters: -game "c:\program files\steam\steamapps\zackcentner\garrysmod\garrysmod" "C:\Users\Zack and Josh\Desktop\my stuff\river_test"

Valve Software - vbsp.exe (May 19 2009)
2 threads
materialPath: c:\program files\steam\steamapps\zackcentner\garrysmod\garrysmod\materials
Loading C:\Users\Zack and Josh\Desktop\my stuff\river_test.vmf
Entity 1: func_areaportal can only be a single brush

** Executing...
** Command: "c:\program files\steam\steamapps\zackcentner\sourcesdk\bin\orangebox\bin\vvis.exe"
** Parameters: -game "c:\program files\steam\steamapps\zackcentner\garrysmod\garrysmod" "C:\Users\Zack and Josh\Desktop\my stuff\river_test"

Valve Software - vvis.exe (May 19 2009)
2 threads
reading c:\users\zack and josh\desktop\my stuff\river_test.bsp
Error opening c:\users\zack and josh\desktop\my stuff\river_test.bsp

** Executing...
** Command: "c:\program files\steam\steamapps\zackcentner\sourcesdk\bin\orangebox\bin\vrad.exe"
** Parameters:  -game "c:\program files\steam\steamapps\zackcentner\garrysmod\garrysmod" "C:\Users\Zack and Josh\Desktop\my stuff\river_test"

Valve Software - vrad.exe SSE (May 19 2009)

      Valve Radiosity Simulator     
2 threads
Could not find lights.rad in lights.rad.
Trying VRAD BIN directory instead...
Warning: Couldn't open texlight file c:\program files\steam\steamapps\zackcentner\sourcesdk\bin\orangebox\bin\lights.rad.
Loading c:\users\zack and josh\desktop\my stuff\river_test.bsp
Error opening c:\users\zack and josh\desktop\my stuff\river_test.bsp

** Executing...
** Command: Copy File
** Parameters: "C:\Users\Zack and Josh\Desktop\my stuff\river_test.bsp" "c:\program files\steam\steamapps\zackcentner\garrysmod\garrysmod\maps\river_test.bsp"

The command failed. Windows reported the error:
  "The system cannot find the file specified."

NEED FIX

[editline]08:43AM[/editline]

anyone?!

you have tied multiple brushes to a func_areaportal. Press the “To World” button on the right while selecting your areaportal, then select each areaportal seperately and tie it to a new areaportal.

you lost me at “func_areaportal”

you have a group of brushes tied to an entity, specifically “func_areaportal” The entity only allows one brush to be tied to one instance of the entity


Valve Software - vbsp.exe (May 19 2009)
2 threads
materialPath: c:\program files\steam\steamapps\zackcentner\garrysmod\garrysmod\materials
Loading C:\Users\Zack and Josh\Desktop\my stuff\river_test.vmf
**Entity 1: func_areaportal can only be a single brush**



i think i found the problem, hold on.

[editline]09:55AM[/editline]

i cant find it. hears a dl link to the vmf. if you can fix it, ill be grateful.

map>entity report
Then look for func_areaportal. You added one at one stage, unless you didn’t make the map, in which case I’d stop right now.

i made this map. ill try to find the func area portal.

[editline]11:22AM[/editline]

found it, thx guys.