Help Fixing An Old Addon

Ok so i’ve recently been given an old addon off the maker of the said addon, but it seems not to work with this current version of darkrp. The errors i get are here:



[ERROR] addons/_toms_clothesshop/lua/clothshop/server.lua:73: attempt to call method 'setCharacterModel' (a nil value)
  1. equipPlayerCloth - addons/_toms_clothesshop/lua/clothshop/server.lua:73
   2. func - addons/_toms_clothesshop/lua/clothshop/server.lua:64
    3. unknown - lua/includes/extensions/net.lua:32

[/]

And here are these lines of code



player:setCharacterModel(model) 




equipPlayerCloth(pl,clothes[cloth].malemodel)





func( len, client )

That helps not at all. Those are custom functions.

setCharacterModel is not a method.

Yeah SetCharacterModel was redundant, removed it and it all worked. Thanks anyway guys,