Help, Fretta automaticaly include classes!

Here’s my problem, I don’t have IncludePlayerClasses() in my shared.lua file but the default class is still being loaded.

Here’s my shared.lua

[lua]
DeriveGamemode( “fretta” )

AddCSLuaFile(“shared.lua”)
AddCSLuaFile(“cl_init.lua”)
AddCSLuaFile(“building_types.lua”)
AddCSLuaFile(“player_classes.lua”)

include(“building_types.lua”)
include(“player_classes.lua”)

GM.Name = “Crash Hazard”
GM.Author = “CrashLemon”
GM.Email = “”
GM.Website = “”
GM.Help = “Kill the other team or something”

GM.TeamBased = false // Team based game or a Free For All game?
GM.AllowAutoTeam = false
GM.AllowSpectating = false
GM.SecondsBetweenTeamSwitches = 10
GM.GameLength = 30
GM.RoundLimit = 10 // Maximum amount of rounds to be played in round based games
GM.VotingDelay = 5 // Delay between end of game, and vote. if you want to display any extra screens before the vote pops up

GM.NoPlayerSuicide = false
GM.NoPlayerDamage = false
GM.NoPlayerSelfDamage = false // Allow players to hurt themselves?
GM.NoPlayerTeamDamage = false // Allow team-members to hurt each other?
GM.NoPlayerPlayerDamage = false // Allow players to hurt each other?
GM.NoNonPlayerPlayerDamage = false // Allow damage from non players (physics, fire etc)
GM.NoPlayerFootsteps = false // When true, all players have silent footsteps
GM.PlayerCanNoClip = false // When true, players can use noclip without sv_cheats
GM.TakeFragOnSuicide = false // -1 frag on suicide

GM.MaximumDeathLength = 0 // Player will respawn if death length > this (can be 0 to disable)
GM.MinimumDeathLength = 0 // Player has to be dead for at least this long
GM.AutomaticTeamBalance = false // Teams will be periodically balanced
GM.ForceJoinBalancedTeams = false // Players won’t be allowed to join a team if it has more players than another team
GM.RealisticFallDamage = false
GM.AddFragsToTeamScore = false // Adds player’s individual kills to team score (must be team based)

GM.NoAutomaticSpawning = false // Players don’t spawn automatically when they die, some other system spawns them
GM.RoundBased = false // Round based, like CS
GM.RoundLength = 60 * 2 // Round length, in seconds
GM.RoundPreStartTime = 5 // Preperation time before a round starts
GM.RoundPostLength = 5 // Seconds to show the ‘x team won!’ screen at the end of a round
GM.RoundEndsWhenOneTeamAlive = false // CS Style rules

GM.EnableFreezeCam = true // TF2 Style Freezecam
GM.DeathLingerTime = 3 // The time between you dying and it going into spectator mode, 0 disables

GM.SelectModel = false // Can players use the playermodel picker in the F1 menu?
GM.SelectColor = true // Can players modify the colour of their name? (ie… no teams)

GM.PlayerRingSize = 48 // How big are the colored rings under the player’s feet (if they are enabled) ?
GM.HudSkin = “SimpleSkin”

GM.ValidSpectatorModes = { OBS_MODE_CHASE, OBS_MODE_IN_EYE, OBS_MODE_ROAMING }
GM.ValidSpectatorEntities = { “player” } // Entities we can spectate
GM.CanOnlySpectateOwnTeam = false // you can only spectate players on your own team

function GM:CreateTeams()

end
[/lua]

Then you need to overwrite the function

Just put an empty IncludePlayerClasses() function in there.

I couldn’t make it work, overwriting IncludePlayerClasses() doesn’t do anything, it still use the default class…

[lua]
function IncludePlayerClasses() end
IncludePlayerClasses()
[/lua]

That’s what I added in my shared.lua

Looking over the fretta gamemode, that function is gonna get executed no matter what, so all you can do is get rid of the class altogether, if that’s even possible.

I can’t because Fretta doesn’t give me control of that. I can find a workaround but it’d be much easier if Garry or Rambo_6 could fix it.

Can’t you just not use that class?