help getting resource.addfile to work

i have a downloads.lua in my garrysmod\lua\autorun\server folder. this is what it contains




--resource.AddFile("maps\rp_cscdesert_v2-1_propfix.bsp")
resource.AddFile("addons\Extra Customizable Weaponry\Models\weapons\w_cst_p90.mdl")
resource.AddFile("models	est.txt")

i just cant get it to work… no matter what i try…

i dont have fastDL enabled yet. but im going to fix that today or tommorow. but theres really no point if i cant add files to be downloaded…

can someone please help me out, tell me what im doing wrong, or give an example…

my real goal is just to be able to transfer these addons i downloaded.

http://www.garrysmod.org/downloads/?a=view&id=131672
http://www.solidfiles.com/d/8d99393b7b/
http://www.garrysmod.org/downloads/?a=view&id=131673

for some reason. the customizable weaponry 1.242 already gets downloaded by clients as they join. but the extra customizable weaponry pack does not…

for the extra pack, u have to transfer some sounds to the garrysmod/garrysmod/script/sounds folder after putting it in addons, so idk if thats even possible to do with resource.addfile, but even if it isnt. ide still like to transfer the models and stuff so they dont get errors… its not too big a deal if the sounds are broken for some guns.

if this should be in garrysmod - help in support, tell me and ill post it there instead. but for some reason. my old post got deleted, i cant search forums and i cant even check my threads and posts(from my profile), it says i dont have permission… and i checked my email. theres no conformation email or n e thing… not even in spam…

any way. any help is much appreciated. and this is like the last thing i have to do for my server. so once i fix this, my server should be up 24/7

thanks

–Edit–

i just noticed that most addons have a /lua/autorun folder which handles resource.addfile()
and that customizable weaponry has one, and the extra pack doesnt.
im gunna try adding models and materials to the extra pack… but all the lua’s in the basic pack are way outta my league.

heres what i have so far… idk if it works yet… but does it look right???

i made a file in /addons/extra customizable weaponry/lua/autorun/server called downloads.lua

It should only be:
Materials/Models/Weapons/w_models/beretta_m9
Starting folder not the entire path. Your slashes have to be “/” not “”.

Ex:
models/weapons/deagle
materials/models/paint

thanks

ok well i tried setting up fastDL for my server… i think i did it correctly. i followed this guide

but after adding:



sv_downloadurl "<myurl>"
sv_allowupload "1"
sv_allowdownload "1"


to my server.cfg, my server refuses to start up… this is what i get…right before it closes

EDIT:

i fixed it… by deleting my cfg folder, and then using hlds update tool to update garrysmod.

EDIT:

ive downloaded filezilla server and connected to localhost. then i set a used “guest” and gave it read only access to a copy of (most)my gmod server folder
then added the sv_ commands to server.cfg
then i forwarded the ftp port

then i downloaded filezilla client. but i cant connect to my external or internal ip addresses. i can only connect via localhost (127.0.0.1)

needless to say. gmod wont connect to the ftp server…

any ideas what im doing wrong? also i cant connect filezilla server to my external ip. but im not sure if supposed to do that

[RESOLVED]