[Help] gm_tmysql error

error loading module ‘tmysql’ from file ‘/orangebox/garrysmod/lua/includes/modules/gm_tmysql_linux.dll’:

libmysqlclient.so.16: cannot open shared object file: No such file or directory

that the problem when i try to running Or Flood Mod On Linux Sever.

i hope someone can help me about that,thanks you.

and what the helll…why i got Justin Biber Picture?

Make sure libmysql.dll is in the outside of the garrysmod/ folder

ill’ check it,thanks you for respond.

You can change your avatar in your profile settings, that is the default forum avatar.

thanks you for help mate.

and joker i check it,the file is outside of garrys mod floder.

libmysql.dll goes in the server folder next to srcds.exe and whatnot, gm_tmysql goes into garrysmod/lua/includes/modules

The Server Running on linux,not on Windows.

The directories are still the same.

I put the files in the currect floder.

They don’t have to be, libraries can be pulled from another place in linux like /usr/lib.

You need to add the the libmysql 16 libraries.

You will need to make a symlink to libmysqlclient.a with the name libmysqlclient.so.16 or you can just rename it to that. You only need that file and libmysql.so.16.0.0

If you are using the linux tmysql you will also need to download boost which should be on the repo, I don’t quite remember as I setup everything so long ago. You should probably ask AzuiSleet.

Hey you where i can found AzuiSleet?

and i will try what you say,thanks you very much.

When i running the sevrer i got that error libmysqlclient.so.16: invalid ELF header.
what the problem?


i put the boost and his type that messege libboost_thread-mt.so.1.38.0: cannot open shared object file: No such file or directory.
what i doing now?

I have this problem as well

libboost_thread-mt.so.1.38.0: cannot open shared object file: No such file or directory

Using tmysql 3 boost for linux.

I thought the libmysql file went in the orangebox folder? It works fine for me that way.

If you’re trying to run gm_tmysql_boost you will need the boost library through your package manager. If you’re on Ubuntu you can install them through apt (apt-get install boost1.38 I believe, might be trickier on 10.10+) but I suspect you’re running CentOS, so here are the bins from my VM:

http://dl.dropbox.com/u/759758/boost.tar

These belong in the LD_LIBRARY_PATH ex /usr/lib.

Know a solution for Ubuntu 11.04 LTS then?
I tried adding karmic repos, and apt-get’ing, but failed to get all the files… Also tried to add the files you posted, failed as well :confused:

Or is there a linux version of the “non-boost” tmysql? Is there any big difference?

Thanks :slight_smile: