[HELP] HUGE Errors with TF2 content in Garry's Mod

My problem(s):

All of the TF2 character models have the same effect on them.
Some of the TF2 weapon models are displaying skins from other Valve games.
The TF2 maps are having texture errors (basically, they dont look like they do in TF2)
When I use the Face Poser on the ragdolls, their head basically implodes and the end result is something similar to The Predator.

An example of what I mean:

http://img12.imageshack.us/img12/8406/plgoldrush0000z.jpg

[As far as I am aware, this is the ‘burning’ effect, isn’t it?]

Any help as to how to identify why the problem has occured, and how to fix it, would be greatly appreciated.

I only know about the Face Poser part, That is because HL2 uses some different Face Posing thingy than TF2 Character, it will always be like that if you use presets. If you use the bars it will work fine though.

Ah, thanks for that, kind sir.

For the main problem, try renaming your garrysmod folder in steam/steamapps/username/garrysmod (this does NOT remove all the default content, that is stored in the .gcf files)
If it dosen’t solve the problem, rename it back.

I just tried that, and the maps seem to be okay now, but the models are still all showing the burning texture.

Do you have TF2 on your computer?
In Gmod Options, is TF2 checked as a game to add content for?

(Pretty common sense things, I know, but it’s the st I got)

Yeah, I have TF2 and the I have checked the box to add TF2 content.

Weapon problem, you mean the shotty? Here is a fix for it http://www.facepunch.com/showthread.php?t=755849

annnd map errors, here is how to fix it- http://www.facepunch.com/showpost.php?p=10570425&postcount=43

Thankyou! Thanks a lot.

Now I just need to find a fix for all the skins using the ‘burning’ texture.

Hmmm, the lava skin problem. I think I read before how to fix. try these

In steam games right click on Gmod, Properties, set launch options and type

-dxlevel 90 or -dxlevel 80

try both, not at the same time

You, sir, are a gentlemen and a scholar.

[editline]07:57PM[/editline]

Quick question:

Each time I start the game, do I have to put the graphics settings back up to high?

Since I’ve used the dxlevel commands it doesn’t seem to save my settings :frowning:

The dxlevel commands should save after launching the game, so you can remove it from launch options and have your settings saved.

Your material settings are really really low, at least it seems so …

XD The face!

Anyway, at the risk of being rated “dumb”, try turning up the graphics settings. And upgrading your graphics card, it shouldn’t be so bad as to have that much trouble with a stock edition of Gmod.

Thankyou.

[editline]10:08PM[/editline]

I have an XFX 9800 GT, lol.

[editline]10:08PM[/editline]

Nope, it’s just the skin.