Help? I'm desperate.

I keep having problems with my new server.

The first problem I had, was that it wasn’t setting my gamemode correctly. I figured that out I suppose.

Now i’m having problems with the HUD not working. The gmod server isn’t recognizing that I want the gamemode’s HUD. It keeps setting it to sandbox’s. I don’t know how to fix it. I’m not sure if this is a darkrp problem, or a problem with the server setting the gamemode correctly. Help? I’m so desperate right now. Thanks

Here’s my server cfg, autoexe, and command line.

-------------------server.cfg------------------------
hostname “[TGS]VISUALISTIC_DARKRP2|BANKROB|GANGS|CARS|50+JOBS|+MORE”
rcon_password “password” // rcon password

sv_password “” //Server Password

//net_maxfilesize 50
sbox_noclip=“0”
sbox_plpldamage=“1”
sbox_godmode 0
sbox_noclip “0”
sbox_godmode “0”
sbox_plpldamage “1”
rp_toolgun “1”
apa_fpp_autoblock = false
apa_nocollideweapons = 0

//Voice Chat
sv_voiceenable 1 // Enable Voice
sv_alltalk 1 // Allow all the teams to talk to each other

// Lan
sv_lan 0 // Lol Lan

//Rates (Don’t change unless you under stand these)
sv_maxcmdrate 33
sv_maxupdaterate 13
sv_maxrate 0
sv_minrate 15000
sv_minupdaterate 13
fps_max 150

//Fall Damage, 1 for realistic, 0 for 10 hp
mp_falldamage 0

//How fast a Spray can be Sprayed, In seconds
decalfrequency 30

// LOGGING
sv_logbans 1
sv_stats 1
log 1

//Leave off unless you want them on. (Most things that crash servers are cheats.)
sv_cheats 0

//Downloading
sv_downloadurl “http://www.tgsgaming.com/fastdl/vis
sv_allowdownload 1
sv_allowupload 1
//net_maxfilesize 20

“sv_lan” “0”
//“maxplayers” “32”
“sbox_allownpcs” “0”
sbox_maxprops 45
“sbox_maxragdolls” “0”
“sbox_maxnpcs” “0”
“sbox_maxballoons” “0”
“sbox_maxeffects” “0”
“sbox_maxdynamite” “0”
“sbox_maxlamps” “0”
“sbox_maxthrusters” “0”
“sbox_maxwheels” “0”
“sbox_godmode” “0”
“sbox_plpldamage” “1”
“sbox_playergod” “0”
“sbox_noclip” “0”
“sbox_maxhoverballs” “0”
“sbox_maxvehicles” “15”
sbox_maxbuttons 7
sbox_maxtextscreens 4
apa_nocollidevehicles 0

sv_loadingurl “http://visualisticstudios.com/loadingscreen/example-background-image.html?id=1048&steamid=%s

“gamemode” “darkrp”
“sv_gamemode” “darkrp”

sv_region 0
sv_timeout 65

//If you want something to not be executed put it like this
//sv_cheats 1

//Make sure the Bans are loaded
exec banned_user.cfg
-------------------server.cfg------------------------

-------------------autoexec.cfg------------------------

sbox_godmode 0
sbox_noclip 0
“sbox_allownpcs” “0”
sbox_maxprops 75
“sbox_maxragdolls” “0”
“sbox_maxnpcs” “0”
“sbox_maxballoons” “0”
“sbox_maxeffects” “0”
“sbox_maxdynamite” “0”
“sbox_maxlamps” “0”
“sbox_maxthrusters” “0”
“sbox_maxwheels” “0”
“sbox_maxtextscreens” “4”
sbox_maxtextscreens 4
apa_fpp_autoblock = false

apa_nocollideweapons 0
apa_nocollidevehicles 0

“gamemode” “darkrp”
“sv_gamemode” “darkrp”
-------------------autoexec.cfg------------------------

cd /gmodds;screen -A -m -d -S GMOD ./srcds_run -console -game garrysmod +maxplayers 32 +map rp_downtown_v4c_v2 +host_workshop_collection 303884804 -authkey 887CB9CF1F693AC8408D9B78E6378A54;screen -x GMOD;

I know it’s messy, but yeah.

Either you made up a decent fake password for your post, or you want to change that.

I’m an idiot obviously. Can you edit your comment now? ha.

You should be changing it rather than hiding it.

it’s changed.

Get rid of


"gamemode" "darkrp"
"sv_gamemode" "darkrp"

from your .cfg files and add

+gamemode darkrp

to your command line parameters.

This is the correct way of doing it. It may not solve your HUD problem.

If it does not, post server and client console log after joining your server.

Caps lock broke?

ACTUALLY YEAH IT’S BROKEN. DEFINITELY DIDN’T USE IT TO GRAB ATTENTION LIKE 95% OF SERVER OWNERS.

I figured out the problem though,

I had some HUD that darkrp was calling, because the stupid thing didn’t realize that it wasn’t really a hud (only a folder called hud, which had nothing in it)

Anyways, that “hud” obviously wasn’t working because it had no scripts, and gmod just put the hud back to sandbox.

Problem solved, thanks for the sarcastic “helpful” answers.

1 person tried to help with the problem,
1 person helped me with almost getting my server trashed by random trolls on facepunch,
and 1 person is just an ass with no time on his hands, that comments on my broken caps lock.

fantastic community.

Thank you person that tried to help <3

Not really, they usually have one of three things:
Coder Hire shit
Compelling Gamemode/Content
Lies