[HELP] Lighting issues or what idk

My map is completely dark but the skybox isn’t affected.
So, I’m stumped. I don’t possibly know what could be leaking the light.

(and yes, I do have a light_env and env_sun)

Check your light_environment’s pitch: I have a feeling it’s pointing up rather than down. FYI, it should be at 90 as opposed to -90 (yes, that is the inverse of the pitch in the “Pitch Yaw Roll (Y Z X)” keyvalue).

I recommend taking pitch/angle/color values for your skybox from this very handy sky list.

Changing the pitch didn’t do anything, really. The entire physical map is still black and the skybox remained lit.

Could you post what values your light_environment is set to (preferably a screenshot of the properties window)? Did you take the values from the sky list? Also, compile log please.

make sure your 3D skybox is not covering the map. I had a similar problem earlier as it seems like the 3D skybox can cast shadows onto the “real” map.

Try to disable shadows on those models in the skybox, especially the citadel and the cloud. Those can cast shadows on your sky camera

I don’t think shadows being cast on the sky_camera would affect the lighting in the map itself.

I would check the shadow proprieties anyways, just to make sure

Compile log!

The 3D skybox is behind and under the map, nowhere close to it. What’s weird is that previously compiled versions of the map worked just fine lighting wise but I had to keep going back to fix errors I found (mainly displacements).

just click the “Point At …” button and click somewhere on the ground/ below the light environment. You lighting should be fixed afterwards.

Like I said, use the sky list. Pick a skybox you like and just copy/paste the keyvalues in exactly.

Adjusting the keyvalues didn’t really do anything besides make the skybox look more rich.
The actual map portion remains dark.

Did that. Didn’t work.

More help would be appreciated.

Maybe you could post your compile log? I had a problem like this a while ago and I believe it had something weird to do with func_detail or something along those lines.

Compile log!

Posted it before. Virtually nothing changed.


GatherLight:         0...1...2...3...4...5...6...7...8...9...10 (1)

        Bounce #1 added RGB(1, 1, 1)


This is rather odd really, it just keeps bouncing 1,1,1 until it reaches it’s 100th bounce and stops.

try using the hammer problem checker to see if you come up with anything (alt+p).

Check your lightmap grid and see if you’ve somehow got an extremely low lightmap value somewhere in the map (2/1/0). If you find any, raise it to 4 or higher.

This has caused a similar issue for me before.

Hah, I was thinking about making a compile module that automatically fixes lightmap problems like that, but people told me it’d be stupid and useless. Guess it’s not such a bad idea after all.

Found a lot of lighting errors. Fixed em’ up.

Before fixing some errors with alt+p; I didn’t notice any lightmaps below 4 in the map. Curious.

Don’t let people tell you what’s stupid and what’s not. It might be really successful among mappers someday!

[editline]6th February 2013[/editline]

Aaaaaaaaaaaand VOILA!

It’s fixed. Thank you so much for the help everyone! (I’ll be sure to give special thanks to ya’ll later on. <3)

Mind saying what fixed it?

I agree with Zanarias, you should post what fixed it for future reference.