help!!!...linux...broke again?

I get into game, but the left half of my screen is spammed with a rendering error “invalid pass, etc, etc” seems to be something with water rendering? I cannot play with this covering half my screen…HELP?

Yeah, me and 3 friends playing on Linux all have the same issue. Most of the game text also gets corrupted after a while.

I’m getting the same type of shit with Ubuntu 14.04.

Invalid pass number (3) for Graphics.Blit. Material=Hidden/Water2/Background, npasses=1

Various text corruption around the map

YESSSS SAME!!! Ubuntu 15.10. Also around rivers are complete purple textures. Also it is rendered unplayable due to the whole screen being spammed by the error message.

I’m getting the same error message but i’m not running Linux… ever since they upgraded unity i’ve had to fight to get the game playable. kinda b.s. imo.

I can’t get it to even start in Linux.

Same problem here on debian stable. The individual distro does not seem to matter though. Seems to be a general problem with the recent update for linux.
The following screenshot illustrates the problem:
http://fs5.directupload.net/images/160304/temp/b97hqs55.jpg
Weird thing is: water which should be seen is not seen at all. Water which should not be seen is visible as magenta (RGB: 255, 0, 255) artifacts.
I hope this gets fixed asap; this is game breaking.

Hello,

I have the same problem (KUbuntu 15.10, all drivers and softwares up-to-date, file checked, game deleted then reinstalled, problems still here)  :

  • a infinite loop of error messages (exactly the same Deth had) displayed upon the chat making it unreadable and the left tier of the screen uneasy to see.
  • some shores portions are pink (magenta ?) and can be seen very far away (even beyond mountain and hills). Any item in the player’s hand put in the sight of those pink shores become pink too (that’s funny ^_^)
  • some trees/bushes are pink/magenta too
  • water was at first completely invisible

I tried some graphic options changing and the best I was able to do was to set the graphical options in «good» (the two lowest and the best graphic modes does not change anything). Now, I no longer have the pink trees and I can see the water but the pink shores are still here with those awful errors.

Hope this could help. Shall I post more screenshots/precision/stuff or is it enough ? The Sir.SuckALot’s screenshot is perfectly accurate of our situation, I think.

Regards,

Patcha

Ok, this just got fixed. That was rather quick. Thanx facepunch!

Guess I’ll stick with windows a little longer. :stuck_out_tongue:

Yup, exactly what’s happening to me, magenta right around the water and being spammed by error message.

They fixed it, but I doubt they will push an update for Linux to only fix it.

A few hours a go I got the same problem with Ubuntu 14.04. I submitted a ticket via http://support.facepunchstudios.com. Before receiving any response, fortunately it’s now fixed. :slight_smile:

:smiley: Then make sure to resolve the ticket.