help me pls rust didnt start (couldnt connect to eac network / eac disconnected: disconnected eac)

every time i try to start rust there comes a window after a couple of minutes which says something like could not connect to easyanticheat network.
if i try to start game from gamefolder i cant join a server because there it says eac disconnected: disconnected eac.

i asked reddit but noone seems to help me out https://www.reddit.com/r/playrust/comments/4ea9v5/steam_says_rust_is_running_but_it_didnt_start/

what i already tried:
-starting steam and game as admin
-reinstalling some drivers
-starting windows in test mode

  • reinstalling eac
  • deactivated avast antivir
  • uninstalling avast antivir (after uninstall i rebooted computer and rust work. but after next reboot i cant play, same bug again)
  • deactivated firewall
  • deactivated windows user acess controll
    -reinstalling rust at c:\ (it was on d:\ before)

my device:
windows 7 home premium (updated)
processor: intel core i5 760
mainboard: msi h55m-p33
graphic card: geforce gtx 760 ti
memory: 12gb

i already used about 4-5 hours of freetime to fix this bug but i cant find out whats wrong :frowning: i searched the internet and tried out so many “fixes” but i seems that no fix worked for me
pls if someone has any idea, i will try everything (but not updating to win10)

thank you already for reading this
meudin

try this once/ Open rust via Folders the launcher without the Icon

Sometimes starting the game as admin will stop Rust from working, but that was awhile ago. Has the game ever worked for you?

yeah yesterday i could play after uninstalling avast antivir, but after reboot the same bug appears.
when i start the rust.exe from folder nothing happens, yesterday i started game and then there was the bug, that i cant join a server because: eac disconnected: disconnected eac
but now i cant even start rust from folder, only with launcher from folder but then i cant join a server too

edit: deactivated admin mode for steam and game but still did not start

So has anyone an idea how to help me? i already waited 2 days :frowning:

Did you ever find a fix? I am having the exact same problem. I tried all the “fixes” but nothing seems to fix it.