Help! My model is an error!

Hello everyone! I have been trying my hardest for the past few days to get a model to work for GMOD, but every time I get him into my addons folder he’s just a giant ERROR on my screen.

this is my third or fourth model I’ve worked on but only this model (who is actually the only normal sized one) wont work.

what I use:
blender
a working player model from the workshop
Crowbar w/Source 2013 multi player

so, after compiling the model, he appears how he SHOULD be in the model maker (but with all his textures)

but then I load him into gmod and/or sfm, and he’s a giant error in one and invisible in the other.

so I tried for the SFM and tf2 compiler settings and same problem. (I got an error for the others since I don’t have the other games or something)

I checked the directories and everything checked out with location, but still nothing.


I’m going to be redoing the model as when I removed the Unicode problem that was occurring when I exported the smd the first time (this is going to be the third time I re-work on him, heh) it actually messed him up in the model viewer.

but any information would be greatly appreciated!

thank you all for your time!

(and just for information purposes, I’m not intending to share this model on gmod, as I do not have the original creator’s permission for sharing this model yet)

You said that the model is invisible in SFM/GMOD, did you check the VMT paths?
And maybe try Crowbar to compile your model. Dunno if it would fix it though.

I did, though it is definitely worth another look, thank you.
and I do use crowbar. I’ve heard some pretty rough things about other compilers, so it’s the only compiler I use.

After taking a look, I found they were one folder too far, so I’ve moved them and I’ll see if that helps later tonight!

thanks again!

Good luck!

well thank you KoenLeung, however I just tried and rechecked everything. I did have a mistake in my VMTs, but when I fixed that there was still an error.

thank you very much for your help though!

hate to be a pest and bumping this after a couple months, but I’ve still had no luck with getting this model to work in GMOD. I feel like I’m missing something important, and any help would be greatly appreciated!

is there something I need to do when working with the VTF/VMTs? I usually try to keep everything as a “vertexlitgeneric” and the paths are all there, but he still shows up as a giant error when I try to load him.

and this last time I tried to re-compile him again after re-weighing and separating him into several pieces his model in the viewer kind of resembled a giant spike ball, but was only a giant error again in game.

thank you again for any help!

If the model appears at the text “ERROR” then it’s not the VMT/VTF’s problem, instead you would be seeing the model with pink and black textures. You most likely put the model in the wrong directory, provide us the model path in the .qc and the path you have in your gmod folder and we can see if there’s something wrong with that, Good luck!