Help on reducing lag on a server?

Hey, this is probably asked really often but, I’ve searched google for hours triying different techniques -.- So, I came here. My ttt server holds up to 36 people. Usually a max of 26 are on though. As soon as it passes 22 the ping of all users goes crazy… Is there something wrong with my cfg? Or is there anything I can add in there to improve this?


log			on

hostname		"TTTFastMine|Minecraft 24/7|Pointshop"
rcon_password		"********"
sv_password		""
sv_region		255
sv_lan			0
sv_logbans		0
sv_logecho		0
sv_logfile		1 
sv_log_onefile		0
sv_noclipspeed		5
sv_noclipaccelerate	5       
gamemode terrortown 1
ulx_minply 1
ulx_roundrestart 
ulx roundrestart 
sbox_allownpcs		1
sbox_godmode		0
sbox_plpldamage		0
sbox_playergod		0
sbox_noclip		1
sv_gravity              300
ttt_postround_dm 1
ttt_no_nade_throw_during_prep 1
ttt_karma_low_autokick 1
ttt_karma_low_amount 699
ttt_karma_low_ban 1
ttt_karma_low_ban_minutes 60
ttt_namechange_bantime 0
ttt_karma_persist 1
ttt_round_limit 10
sv_allowdownload "0"
sv_allowupload "0"
sv_loadingurl "mudgaming.org/Load/index.php?sid=%s"
ttt_playercolor_mode 0
sv_kickerrornum 0

sbox_maxprops		150
sbox_maxragdolls	5
sbox_maxnpcs		10
sbox_maxballoons	10
sbox_maxeffects		50
sbox_maxdynamite	10
sbox_maxlamps		20
sbox_maxthrusters	30
sbox_maxwheels		20
sbox_maxhoverballs	20
sbox_maxvehicles	6
sbox_maxbuttons		20
sbox_maxsents		20
sbox_maxemitters	5
sbox_maxspawners	3
sbox_maxturrets		2

net_maxfilesize		200

sv_mincmdrate 0
sv_maxcmdrate 40
fps_max 150
sv_minrate		20000 
sv_maxrate		0
decalfrequency		10 
sv_maxupdaterate	66 
sv_minupdaterate	10
sv_stats 0

// execute ban files
exec banned_ip.cfg 
exec banned_user.cfg 

Is this a rented server or are you hosting your own server from home? If you’re hosting your server from home, it could be your bandwidth.

[editline]29th January 2014[/editline]

Also, take out sbox_plpldamage, if I’m correct it’s not a command anymore.

try setting the the tick rate to 33

  1. Remove your RCON password from your server.cfg

  2. Go to the “Command Line Changer” option on the main page of your game server panel. If applicable

  3. Use the “+rcon_password” option, and insert your RCON password into the textbox and save. If applicable.

You could also add

to your command line
Also add

to your command line

@Eratic It’s a Web Host. And Alex I will try that.

I’m pretty clueless on how to add a Command Line… The Owner of the server is currently away so I can’t ask him. We use FPSplayers to host this server. This is what I see. When I click on “new” I also see the same thing, however the Description box is empty.

http://gyazo.com/eca746e2b12586673248ca5ad9f7e01e.png

Great tell me if you have any other issues :slight_smile:

In the above post, I’ve posted an edit. I’m pretty clueless about the Cmd…

Okay.

What is the top line.

The top one that is blurred? you do not need to tell me. Just tell me the local ent?

Its the username for the account. I don’t really think that would help though. I sent a ticket to my provider asking how to edit it. Hopefully they’ll help.

That should fix the issue :slight_smile: