Help please: Unable to join servers

System hardware specs:

  • Processor: AMD Phenom II X4 965 Processor (4CPUs), ~3.4GHz
  • RAM: 4096MB RAM
  • Graphics Card: NVIDIA GeForce GTX 285
  • Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600)

Phoenix
Assmod
Wiremod
Smartsnap

When I attempt to enter a server I begin to download all the files it tells me to automatically, as usual. Once it gets to the very last file my game freezes up, and I am unable to navigate to the main menu. The only way to exit the game is to then end the process from the task manager.
I tried to re-enter the same room after apparently downloading all the required files, however it still made me download more, and the same problem occurred.

[Edit] I just noticed that it seems to freeze up on the “Retrieving server info” part of the joining process. This may help.

You’ve tried to just wait right? sometimes the loading is very slow at retrieving server info, try to give it a few minutes…

Yeah, I left it on that as I ate dinner, for about 30 minutes. I came back and it was frozen in the same spot.
I noticed when I quickly tried the same server again it would say that someone with my IP was already connected or something of the sort.