Help with compiling a .SMD to a .MDL

Ok, so… I have been working on a pretty basic model using XSI Mod Tool. I got the textures, the model, bla bla bla… I now have all the files I need (According to other tutorials, http://www.vimeo.com/4319285) which is the .QC file for compiling, and the three model types. (I think one is a texture, idk, they are all .SMD files and I have a .png one.) I’m currently TRYING to use GUIStudioMDL for the compiling process. This is the bullshit (Sorry :P) I get when trying to compile.

Created command line: “C:\Program Files\Steam\steamapps*MYSTEAMNAME*\sourcesdk\bin\ep1\bin\studiomdl.exe” -game “C:\Program Files\Steam\steamapps*MYSTEAMNAME*\garrysmod\garrysmod” -notxbox C:\Users\Administrator\Desktop heqc.qc

qdir: “c:\users\administrator\desktop”
gamedir: “C:\Program Files\Steam\steamapps*MYSTEAMNAME*\garrysmod\garrysmod”
g_path: “theqc”
Working on “theqc.qc”
SMD MODEL Ship_idle.smd
SMD MODEL Ship_phys.smd
ERROR: ‘EXCEPTION_ACCESS_VIOLATION’ (assert: 1)
ERROR: Aborted Processing on ‘models\clambmodels\ship.mdl’

And, before using a nicer .QC, I’d get

ERROR: c:\users\administrator\desktop hingy.qc(3): - bad command Ship_ref.smd
ERROR: Aborted Processing on ‘clambmodels/ship.mdl’

WHAT THE HELL DOES THAT MEAN!!! Lol, is there any other kind of compilers I should try out? Maybe someone could help me write a different .QC file, or, well… I don’t know. I just need some help… And after two days of not even doing my homework and trying to figure this out, it’s just killing me. Thanks for any help.

(Yes, I have seen this tutorial too for compiling http://www.facepunch.com/showthread.php?t=501102)

Can we have a look at the .qc? It could be the problem. I know I had the same problem when I was trying a citizen model.

i see you are running vista. are you running the program as an administrator? like doing the full on right-click run as administrator, not just the user.

Sure, no problem.

$modelname “clambmodels/ship.mdl”
$cdmaterials “clambmodels\ship”

$scale 1
$surfaceprop “metal”

$sequence idle “ship_idle.smd” fps 1

$collisionmodel “ship_phys.smd” {
$mass 100.0
$inertia 1.00
$damping 0.00
$rotdamping 0.00
}

$modelname “clambmodels/ship.mdl” replace that with $modelname “clambmodels\ship.mdl”

Mehhh… Still have the same error.

ERROR: ‘EXCEPTION_ACCESS_VIOLATION’ (assert: 1)
ERROR: Aborted Processing on ‘clambmodels\ship.mdl’

Here is another QC I have been trying as well.

$modelname “clambmodels/ship.mdl”
$scale 1.0
$cd “Body” “Ship_ref.smd”
$cdmaterials “clambmodels\ship”
$sequence idle “Ship_idle.smd”
$surfaceprop “metal”
$collisionmodel “Ship_phys.smd” {
$mass 50.0
}

[editline]01:21PM[/editline]

(Forgot to add)

Here is the error I get :frowning:

qdir: “c:\users\administrator\desktop”
gamedir: “C:\Program Files\Steam\steamapps\jerryhelmutmartin\garrysmod\garrysmod”
g_path: “thingy”
Working on “thingy.qc”
ERROR: c:\users\administrator\desktop hingy.qc(3): - bad command Ship_ref.smd
ERROR: Aborted Processing on ‘clambmodels\ship.mdl’

Even after I did what Wootman said, I get the same error… All the models are on desktop if your wondering why my qdir is on desktop.

Try this:


$model "Body" "Ship_ref.smd"
$cdmaterials "clambmodels\ship"
$sequence idle "Ship_idle.smd"
$surfaceprop "metal"
$collisionmodel "Ship_phys.smd" {
$mass 50.0
}

Sweeeeet SWEEET progress. This is what happened, only a small error thingy I guess.

Loaded QC file - “C:\Users\Administrator\Desktop hingy.qc”

Created command line: “C:\Program Files\Steam\steamapps\jerryhelmutmartin\sourcesdk\bin\ep1\bin\studiomdl.exe” -game “C:\Program Files\Steam\steamapps\jerryhelmutmartin\garrysmod\garrysmod” -notxbox C:\Users\Administrator\Desktop hingy.qc

qdir: “c:\users\administrator\desktop”
gamedir: “C:\Program Files\Steam\steamapps\jerryhelmutmartin\garrysmod\garrysmod”
g_path: “thingy”
Working on “thingy.qc”
ERROR: c:\users\administrator\desktop hingy.qc(3): - bad command Ship_ref.smd
ERROR: Aborted Processing on ‘clambmodels\ship.mdl’
Loaded QC file - “C:\Users\Administrator\Desktop\poop.qc”

Created command line: “C:\Program Files\Steam\steamapps\jerryhelmutmartin\sourcesdk\bin\ep1\bin\studiomdl.exe” -game “C:\Program Files\Steam\steamapps\jerryhelmutmartin\garrysmod\garrysmod” -notxbox C:\Users\Administrator\Desktop\poop.qc

qdir: “c:\users\administrator\desktop”
gamedir: “C:\Program Files\Steam\steamapps\jerryhelmutmartin\garrysmod\garrysmod”
g_path: “poop”
Working on “poop.qc”
SMD MODEL Ship_ref.smd
SMD MODEL Ship_idle.smd
SMD MODEL Ship_phys.smd
Model has 1 convex sub-parts
Collision model completed.
The filename, directory name, or volume label syntax is incorrect.

writing C:\Program Files\Steam\steamapps\jerryhelmutmartin\garrysmod\garrysmod\models/C:\Users\Administrator\Desktop\poop.mdl:
Error opening C:\Program Files\Steam\steamapps\jerryhelmutmartin\garrysmod\garrysmod\models/C:\Users\Administrator\Desktop\poop.mdl! (Check for write enable)

Change your .qc to:


$modelname "clambmodels/ship.mdl"
$scale 1.0
$model "Body" "Ship_ref.smd"
$cdmaterials "clambmodels\ship"
$sequence idle "Ship_idle.smd"
$surfaceprop "metal"
$collisionmodel "Ship_phys.smd" {
$mass 50.0
}

Use GUIStudioMDL as a program without any of the -'s in the command box. Then load up your .qc, and select an Orange Box game folder to compile to (TF2, DoD:S, HL2: EP2, Portal or search for your GMod gameinfo.txt) and then hit compile. Then if you compiled to a game other than GMod, copy the model files over.

Also, you will need to make sure that the folders are there wherever you compiled to (so models/clambmodels).

Ok, thanks. I wil try when I return from school. (About 5 hours from now) Hopefully it’ll work.

(THE RESULTS: Lol, we have success. :slight_smile: Completed “thingy.qc” One thing… Where the hell is the model?

Another Edit. Ok, I found the model and we have one last problem. THE TEXTUREEEEEE! It’s all screwed up and pink and black, otherwise, I can see it in-game GMOD.

This .qc file does not work.


$modelname "models\subdir\modelname.mdl"
$cdmaterials "subdir\"

$scale 1
$surfaceprop "metal"

$sequence idle "modelname.smd" fps 1

$collisionmodel "modelname.smd" {
$mass 100.0
$inertia 1.00
$damping 0.00
$rotdamping 0.00
}

This .qc file does work. Does anyone know why?


$modelname "models\poop\poop.smd"
$scale 1.0
$model "Body" "poop.smd"
$cdmaterials "models\poop"
$sequence idle "poop.smd"
$surfaceprop "metal"
$collisionmodel "poop.smd" {
$mass 50.0
}