Help with creating a viewmodel

Hello Facepunch.

I’m having troubles with creating a viewmodel, i really don’t know what the problem is but I can’t see it in-game(It only shows up in SourceSDK).

http://img828.imageshack.us/img828/3180/pci.png

Maybe i have something wrong in the .qc file.



$modelname "Weapons/v_crowbars.mdl"
$model "studio" "crowbar_reference.smd"
$cdmaterials "models\Weapons\V_hand\"
$cdmaterials "models\Weapons\V_crowbar\"
$hboxset "default"
$hbox 0 "ValveBiped.Bip01_Spine4" 0.000  0.000  -1.938  2.033  1.001  0.000
$hbox 0 "ValveBiped.Bip01_R_UpperArm" -1.763  -2.283  -2.700  11.693  4.552  3.363
$hbox 0 "ValveBiped.Bip01_R_Forearm" -1.958  -3.135  -2.804  11.482  2.550  3.047
$hbox 0 "ValveBiped.Bip01_R_Hand" 0.000  -3.141  -19.575  10.937  0.794  14.726
$hbox 0 "ValveBiped.HandControlRotR" 0.000  -1.935  -15.150  11.123  0.000  0.000
// Model uses material "crowbar_cyl.vmt"
// Model uses material "v_hand_sheet.vmt"
// Model uses material "head_uvw.vmt"
$attachment "0" "ValveBiped.Tip" 0.00 -0.00 -0.00 rotate -0.00 -0.00 0.00
$surfaceprop "default"
$illumposition 25.370 -8.644 -15.379
$sequence idle01 "idle01" loop ACT_VM_IDLE 1 fps 30.00
$sequence draw "draw" ACT_VM_DRAW 1 fps 30.00
$sequence misscenter1 "misscenter1" ACT_VM_MISSCENTER 1 fps 30.00
$sequence misscenter2 "misscenter2" ACT_VM_MISSCENTER 1 fps 30.00
$sequence hitcenter1 "hitcenter1" ACT_VM_HITCENTER 1 fps 30.00
$sequence hitcenter2 "hitcenter2" ACT_VM_HITCENTER 1 fps 30.00
$sequence hitcenter3 "hitcenter3" ACT_VM_HITCENTER 1 fps 30.00
$sequence hitkill1 "hitkill1" ACT_VM_HITKILL 1 fps 30.00
$sequence holster "holster" ACT_VM_HOLSTER 1 fps 30.00


Try swapping “fps” with “snap rotate -90 fps”.

What do you mean exactly, i am new at modelling.

He means add rotate -90 to the end of all the sequences.

I don’t see how snap would help at all with the problem.

Why is there no origin line?

I don’t know,but the model no have a origin line,Will it be problem?
and i don’t know how create a viewmodel… :confused:
Only I substituted the model of the crowbar and I joined it with the bone.

Are the rotations messed up? Often I have found that the model gets rotated to the side. Go to Options > Viewmodel Mode in HLMV, and if you can’t see the model, rotate the camera around to look for it as it may be rotated.

Check your materials

[editline]08:28PM[/editline]

If it’s a decompile, add “rotate -90” to the end of each $sequence.

Ok thanks for the help i going to try. ^^

[editline]02:16PM[/editline]

Already the model work :smiley: thanks boys :smiley:

[editline]02:35PM[/editline]

http://img72.imageshack.us/img72/2609/eqww.png

Uploaded with ImageShack.us

It is not very good, but I am working in order that it is the best :stuck_out_tongue:

Thanks boys:D