Help with ents.Create & "phys_constraintsystem".

ok, as u might have gathered from the title i am trying to create a “phys_constraintsystem” entity. my problem is when i make it it says that its entid = 0. Also when i look to see if its a valid ent it comes back as true. ima kinda confused so hopefully some one can shed some light. This is the first time i have used ents.Create so i am probably missing some dumb ass thing.

my code =



        local cs = ents.Create("phys_constraintsystem")
	cs:Spawn() -- have tried with and with out this
	cs:Activate() -- have tried with and with out this
	print(cs:IsValid()  ) -- outputs true
	print(cs:EntIndex() ) -- outputs 0


also…

if that helps

thanks for reading and i hope u can help.

You need the Spawn and Activate. Don’t remove those. But your suppose to add a location of where it will spawn.
**[Ents.Create

http://wiki.garrysmod.com/favicon.ico](http://wiki.garrysmod.com/?title=Ents.Create)**
Try that as an example

I wouldn’t even bother trying to manually creating constraints and constraint system. Garrys mod keeps an index of only the constraints made using the constraint.weld or what ever functions. Your going to run into alot of problems if you try to create them manually. Why are you trying to do it this away?

yea, no the setpos had no effect…

I’m guessing that’s because it could be very interesting if it ended up working as advertised.

so any one know why this hates me?

What is advertised?

The thing is spawned, constraints don’t have an entitiy index. Do you even know what a constraint system is?

i am hoping it works like http://developer.valvesoftware.com/wiki/Phys_constraintsystem says it dose.“as advertised”

You do realize that these are already used when you weld things or axis things. Garry already uses these.

ahh… i just did a serarch for them when i had a bunch of welds out and i did get some to come up. ok ima satisfied.