Help with FastDL / Steam Workshop

I really need help with this. I can’t seem to get FastDL / Steam Workshop working on my server, and I am running into other issues as well.

Before I setup FastDL, I was using Steam Workshop to get maps and addons, etc, to the players. That worked fine, except it was a little slow for getting maps (slower than FastDL when I set it up later). I setup FastDL and it works (for maps, at least); players connecting get the maps from FastDL and not Steam Workshop (I removed them from my server’s collection). I still, however, am using a Lua file to tell the clients to download a Steam collection.

After enabling FastDL however, it seems that players don’t download anything from the collection anymore. It will say “Getting collection #randomnumber” when I connect, but I don’t know if that actually does anything because I have subscribed to all the individual items in my collection. I asked my admins if they could see any of the icons for the custom items we have in the T shop, and they said they couldn’t (I could though).

I still have to test unsubscribing and deleting the downloaded addons, but I don’t think that will do anything, as my admins didn’t download them on join.

Does enabling FastDL disable Steam Workshop downloads?

That is my problem with Steam Workshop, however I am trying to setup FastDL so I don’t run into these problems. I know that maps work fine with FastDL, I just can’t get anything else to send. My FastDL URL is www.opgaming.net/fastdl. As you can see if you go there, I have a maps folder, materials, models, and sound.

I have tried what the old Wiki said to do (which is to go into the server addons, and if the path was “addons/myaddon/models/“, I put whatever was in “models” in the models folder on the FastDL server), thus “extracting” the addons.

I have a Lua fastdl.lua that is in my autorun folder, and it basically looks like this:



if SERVER then
	resource.AddFile (“addons/myaddon/models/pathtomodel/mymodel1.mdl”)
	resource.AddFile (“addons/myaddon/models/pathtomodel/mymodel2.mdl”)
	resource.AddFile (“addons/myaddon/models/pathtomodel/mymodel3.mdl”)
	resource.AddFile (“addons/myaddon/models/pathtomodel/mymodel4.mdl”)
end


I have also tried removing the “addons/myaddon” so that it looks like “models/pathtomodel/mymodel1.mdl”, but that didn’t force the clients to download, either.

I even tried putting the same thing in the addons/myaddon/lua/autorun/mymodel.lua, with the second path, to no avail.

I know I have the paths right in PointShop, because when I join, I can see the models in the shop, but everyone else can’t (I am the only one subscribed to the addon).

If you need any more info, please just ask. I really want to get this fixed.

[editline]22nd January 2014[/editline]

Sorry, those resource.AddFile’s should not have a space. I can’t edit the post (blank).

You can use FastDL and Workshop at the same time. However, I disregard from it because I have a hundred reasons to prove why FastDL is so much better than Workshop. The ONLY downside of FastDL is that most people have a hard time getting the hang of it but once you do, it’s so much better.

Now, let’s get on with your issues.

First off, change your fastdl.lua to look like this: (You are using very weird quotes around the path to the model)



if SERVER then
	resource.AddFile("addons/myaddon/models/pathtomodel/mymodel1.mdl")
	resource.AddFile("addons/myaddon/models/pathtomodel/mymodel2.mdl")
	resource.AddFile("addons/myaddon/models/pathtomodel/mymodel3.mdl")
	resource.AddFile("addons/myaddon/models/pathtomodel/mymodel4.mdl")
end


Your FastDL is setup correctly.
You don’t have to place the models/addon in the root of your garrys mod folder, you can keep them in the addons folder and still have the fastdl.lua inside /lua/autorun.

I highly suggest you to just skip using Workshop for your server and just use FastDL.

Sorry, they should be like that, it was a typo and I can’t edit it (getting the old blank edit screen).

What I meant by extracting it is that I am not extracting it to my garrysmod root folder, I am putting the internals of the addons onto my FastDL server (as you can see).

For example, addons/myaddon/models/pathtomodel/mymodel1.mdl will remain the same on my VPS, but on my webserver it will be models/pathtomodel/mymodel1.mdl.

And yes, I also agree that FastDL is better. I just can’t seem to get it to work.

[editline]22nd January 2014[/editline]

And about the quotes, yes, that is not my real code, I was typing in TextEdit and it does the weird quotes.

That is exactly correct.

Make sure your server.cfg settings are as follows:



sv_downloadurl "http://www.opgaming.net/fastdl/"
sv_allowdownload 0
sv_allowupload 0 // Security measure, so make sure it's set to 0.


And I am going to be a little annoying here and tell you to tripple check that the path to your model is correct.

For the issue that you can’t edit your first post, you press the Reply button and you should get the actual BBCode that’s in there and copy it over to your original post.

I’ll be able to check stuff in about 2 hours, I’ll get back to you then.

[editline]22nd January 2014[/editline]

And yes, that’s exactly how my server.cfg is

So, is this a bad error when I trying to use FastDL?



HTTP failed - ISteamHTTP isn't available! 


Everyone gets that error; nothing to do with FastDL.

Well, everything should be working perfectly fine.

How do you even setup a fastdl folder on your server?

You have to have a webserver.

Anyways, I got FastDL working with everything except Models :tinfoil:

Do you need the materials folder in a models addon?

[editline]22nd January 2014[/editline]

Hehe, nevermind. I get really good at this and then I screw up the paths. I will post my retested results. :slight_smile:

If you ever have ShopDL use this


resource.AddWorkshop("WorkshopID")

Or he can just use FastDL like he’s been trying to do.

Ok, FastDL works. I get all the models, etc on joining, but Pointshop still displays them as errors. What am I doing wrong?

I have my model on the server in: addons/halo3models/models/player/halo3/spartan_blue.mdl
I have my model on the FastDL in: models/player/halo3/spartan_blue.mdl

For pointshop, I have tried setting the model path to both above, yet when I open the shop, they are ERRORS instead of the models.

FastDL is working, I checked in my downloads folder in my garrysmod folder, and it is the same as my FastDL server. What could be going wrong?

I also uploaded and downloaded the .vmt and .vtf files, not just the .mdl and associated files.

Post your pointshop code.



ITEM.Name = 'Spartan Blue'
ITEM.Price = 250
ITEM.Model = 'addons/halo3models/models/player/halo3/spartan_blue.mdl'

function ITEM:OnEquip(ply, modifications)
        if not ply._OldModel then
                ply._OldModel = ply:GetModel()
        end

        timer.Simple(1, function() ply:SetModel(self.Model) end)
end

function ITEM:OnHolster(ply)
        if ply._OldModel then
                ply:SetModel(ply._OldModel)
        end
end

function ITEM:PlayerSetModel(ply)
        ply:SetModel(self.Model)
end


I have 3 of these, all exactly the same except for the name (one is pink, the other is green)

Change ITEM.Model to just models/player/halo3/spartan_blue.mdl

As I stated before, I tried that, and it didn’t work. I’ll try again though.

[editline]22nd January 2014[/editline]

Nope, that didn’t work. Same problem.

Just try moving everything from the addons/halo3models directory to the root of your GMod dir.

Ok, that worked, but now the models are covered in checkered boxes. How can I fix that?

You need to send the textures too.