help with Putting addons on servers (Not working for me)

Hi,

Ive ben trying to get a range of addons to work on my sever, I add them and run SourceRSC to put all the custom files on my Fastdl and run the server… I don’t download the custom files and the addon does not work, I test it in single player and it works (After i tested it on my server, i then add the addon to my files before you say “If you had it already it wont download”). Only very few of the addons i got work Like Evolve, Aircraft pack and wiremod. What is going on here? (Haven’t had a server in 2 years, so things might have change)

Ive tried using resource.addfile.Lua’s, I download the files but the addon still does not work.

Also im having problems with SourceRCS if anyone can help here, It keeps repacking a few files every time I run it and then those files don’t seem to work on the server. Whats causing this?

Thanks,
Kennyist.

Addons (Folder with info.txt inside) need to go in addons folder. Any custom materials/models will need to have the resource added manually in a lua file like this:


resource.AddFile("models/model.mdl")

You can then put the lua file inside the lua/autorun/server folder and it will executed on server startup. If using FastDL, the files will need to be on there as well following the same directory structure.

More help with FastDL here: http://maurits.tv/data/garrysmod/wiki/wiki.garrysmod.com/index70e8.html?title=Setting_up_sv_downloadurl

I’ve done all that as i said;

“Ive tried using resource.addfile.Lua’s, I download the files but the addon still does not work.”

A few addons are working, But lots are not and lots of models (That do download to the users) Pc still show up as errors and so on. Is Bzip not supported any more or something wrong with it. I cant work his out as every custom file is uploaded to FastDL and i have resource.addfile LUA’s for the addons and models I want the users to Have. But left some alone like Wire since its massive (but that works on the server).

oh, PS. I have been over the wiki many times.

Heres another example: www.garrysmod.org/downloads/?a=view&id=128433

I downloaded that, addded it to FASTdl ETC. but still its an error in game.

Then you didn’t put it on your FastDL server

I did, It I saw it download the files, all the names.

no, it TRIED to download the files, otherwise it wouldn’t be an error

Well I worked out the model error, It wont download .Bzip files for some reason. But still dont see why all my addons ive added do not work.

because of the random capitalization probably…

:/. Maybe. Also i’ve just added some new textures as trails for Goldenforge. Added a resourceDLf file, There in my fast dl (Not bzipped) But they wont download to anyone, So everyone just gets black and purple. Whats going on here?

Never mind, Seems to be fixed now.