Help

In Gmod my toolgun has stopped working. it is a error model and has ammo. it dosent shoot but has recoil i tried to spawn a tool entity but it has a error message involving a null entity. i have tried downloading a new toolgun but it isnt working

Post addons folder.

what do you mean

Post a screenshot of what you have in your addons folder, so we can see if it’s an addon that’s messing up the toolgun.

i have tried taking a screenshot but my brother has costomised his laptop to a new theme so i cant find where the clipboard is

Press print screen on your keyboard
Open paint
Hit ctrl + v

:rolleyes:

ok

[editline]03:50PM[/editline]

it wont let me paste it onto facepunch

[editline]03:56PM[/editline]

anyway the problems started to late after the last addon i downloded so i doubt the addons would have affected the toolgun

Make an account at photobucket.com, upload to there and give us the link.

You couldn’t even try removing the addon which you know caused the error before asking us…?

the proplem is i dont know the error!

The error is that your toolgun has stopped working.

And it sounds like you installed an addon which broke it.

So uninstall the most recent addon you’ve installed.

not true, the problem is the new gmo fonts have messed up the toolgun screen. so all i need to do is download a new toolgun model and replace the broken one

  1. Right-click Garry’s Mod in your Steam games list
  2. Click “Properties”
  3. In the window that appears, click the “Local Files” tab
  4. In the “Local Files” tab, click the button that says “Verify Integrity of Game Cache”
  5. Let it run

What this does is looks through your game file for any missing/corrupted files then redownloads them.

All my weapons except pistol, physgun, gravg and toolgun didnt worked for a while ago.

How did i fix it? - Reinstall.

I think it was an addon though.