Hexed Weapon sounds dosen't work

I just had success hexing my first weapon, an XM8
I hexed three other weapons aswell but they all had the problem that the sound wont work.
I did specify the right path to my shooting sound in the shared.lua file. (weapons/xm8/xm8-1.wav) but it dosent work, and the animation sounds neither.
How can I fix that? Do I need to hex the model to take advantage or anything else? Because I cant really figure it out.

bump

Isn’t ther anyone who can help me with my problem? :frowning:

You need to add a " at the beginning and end of


(weapons/xm8/xm8-1.wav)

So it should look like this,


("weapons/xm8/xm8-1.wav")

.

And as for the reloading sounds, I’m not sure if using the scripts anymore so what I do is use Audacity to combine all of the sounds of the reload process, you just need to make sure that you time it right. To do that, you would use this piece of lua…


 
function SWEP:Reload()

	self.Weapon:DefaultReload(ACT_VM_RELOAD) 
	-- Animation when you're reloading

	if ( self.Weapon:Clip1() < self.Primary.ClipSize ) and self.Owner:GetAmmoCount(self.Primary.Ammo) > 0 then
	-- When the current clip < full clip and the rest of your ammo > 0, then

		self.Owner:SetFOV( 0, 0.15 )
		-- Zoom = 0

		self:SetIronsights(false)
		-- Set the ironsight to false
self.Weapon:EmitSound("weapons/ak74/reload.wav")
end
	
end

That’s an example from my AK74, but what you would do is replace “ak74” with “xm8” and then replace “reload” with the name of your complete reload sound. It’s more complicated than using the process with the scripts, which I use to know how to do, but I’m not sure anymore. Good luck, and let me know if it works.

Edit:
Also, this is the wrong section. This should be in the lua section.

I tought it was a hexing and model problem, thats why I placed it there.
But i’ll test it and report back soon. Thank you for the help. :slight_smile:

Didnt work :confused: