"Hey, that's mine" - TF2 pose (Needing help as well)

http://filesmelt.com/dl/tc_meridian_rc30001.jpg

Also, I need seriously help. As you can see, my lines are EXTREMELY jagged. Horrible.
I tried saving it on JPG, then PNG, but they look exactly same. Maybe it’s the new graphics drivers I’ve installed? If I can’t fix this, is there a possibility of making the lines smooth from somewhere else?
I don’t remember them being that jagged. Thanks for advance.

http://filesmelt.com/dl/hl2_2010-10-03_15-32-07-78.png

That does look surprisingly jaggy for 8x.

Can you give us your System Specs?

Try 4x msaa

Still as bad. 2x has the same effect.

As well, system specs;

System Information

Time of this report: 10/3/2010, 16:08:58
Machine name: IKT-6NRLEYW7FC2
Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.100427-1636)
Language: Finnish (Regional Setting: Finnish)
System Manufacturer: System manufacturer
System Model: System Product Name
BIOS: BIOS Date: 05/20/09 09:35:52 Ver: 16.04
Processor: AMD Athlon™ II X2 250 Processor, MMX, 3DNow (2 CPUs), ~3.0GHz
Memory: 3072MB RAM
Page File: 2345MB used, 2610MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode

did you change something in the settings of your graphics card control center? when I changed the AA settings in the control center, the AA ingame got worse

Exactly, check if the aliasing isn’t forced in your drivers.

Aliasing isn’t forced in my drivers, default is same. I have changed nothing in my graphics control center.

Guess it’s my graphics card dying.
Okay, in advance, how do I fix these jagged lines if my AA doesn’t work? Some sort of tool, program, etc?