Hide Mouse Cursor on Derma but still allow input?

Hello, I’m trying to make a tablet using a derma frame (DFrame).

Right now I’m using a DButton and setting it’s position automatically with gui.MouseX() and gui.MouseY().
When I paint over the button with a texture, the mouse cursor still appears.
Is there anyway to make it so that people can still use the derma buttons but not see the cursor? I’ve tried using MakePopup() on the frame and then calling gui.EnableScreenClicker(false) afterwards, but that doesn’t seem to do anything.

Example:

Maybe

Panel:SetCursor with the “none” argument?

Sadly that didn’t seem to work. I tried using SetCursor(“none”) on the main panel, and the button itself. but again, nothing.

Edit: lol, I tried setting it to “blank” and that appeared, to work but when you hover over a button, it re-appears.

Make sure you use it on the right “panel”. What you consider the main one, might not be the main one the cursor is using. Code would help too.

Here is an example of one of my menus that effectively uses it and works to this moment.
[lua]function PANEL:Create(Font)
surface.SetFont(Font)
self.w, self.h = surface.GetTextSize(“Current Model”)
self.Font = Font

self.CurrentModel = vgui.Create("DModelPanel", self)
self.CurrentModel:SetPos(0, 0)
self.CurrentModel:SetSize(self:GetWide(), self:GetTall()-(self.h+4))
self.CurrentModel:SetModel(LocalPlayer():GetModel())
self.CurrentModel:SetCamPos(Vector(50,50,50))
self.CurrentModel:SetFOV(35)
self.CurrentModel:SetCursor("none")
self.CurrentModel:SetMouseInputEnabled(false)

end[/lua]

Yeah, ended up running SetCursor with OnCursorEntered for my buttons and that worked fine.

Thanks!