High FPS - Horrible stuttering issues.

Since the update, I haven’t really tried multiplayers; Until today which I decided to give it a go.

In singleplayer, I am running at 120-150 fps (FULL AA) with multicore rendering on, and max settings available. I can’t spawn numerous of objects, without even getting a single stutter, or fps drop. I though that the case would be the same for Multiplayer - But it wasen’t.

The server I entered was an RP server, I turned on console and entered the command to show my fps. It was at 100+. So I started walking around, and I noticed the horrible stuttering, I was lagging every 2 seconds, it was like I had 2 fps. But the text still said 100 fps. SO I though it was a network issue, and checked the scoreboard, where my ping was at 30. I tried numerous servers, and they all gave me a horrible stutter. It was worst when joining a build server.

What could be the issue? I have a 9800GT, and 6GB RAM with i7 920.
Please, help me facepunch (And fellow modders)

For which game?

Please tell me you are kidding.

Garry’s Mod is laggy in general. I think it’s the result of no precaching.

Well, I am still searching. There may be an answer to this.

Then why is not it laggy for me the slightest bit? I am talking for both internet lag and FPS issues.